Printing from the Librem5?

I was just thinking, it must be possible eventually to add a network printer to the L5, as it’s just a computer at heart. Is that something the team is looking at adding someday?
Realizing it’s probably not a high priority right now…

There’s no reason in my mind why it wouldn’t be able to print now, if you installed the appropriate cups packages and other software and configured it. I imagine a more easily discoverable way to configure it would come at some point, but like you said, it’s a lower priority than other things.


I figured that would be the case. Thanks! This thing gets “cooler” by the minute. :slightly_smiling_face:


I played around with this a bit:

My Brother HL-5370DW B/W laser printer is plugged into my router by ethernet (and turned on). My laptop prints over wireless, no problem.

I installed the package Print Settings from the PureOS store to the L5.
Have to shrink the UI considerably to see everything (and then use a magnifying glass to see).

Edit: Also installed cups package from the terminal.

Tried to add a network printer, but it wants a user and password… Everything I could think of to try was rejected: purism+my pin; pureos+my pin; purism+123456, my laptop username+password, blank+blank, etc. (BTW, there are no access controls set on my printer.)

I tried adding the UI’s included generic laser printer drivers, but can’t get past the password control.

A notification pops up telling me a program wants to add additional package and to view it in PureOS store (nothing there).

A conundrum…

with cups service running try opening https://localhost:631/admin/conf and when asking for password provide your local user creds (purism+pin)

Failing that, you may have to set up CUPS admin privileges for your user account first:

usermod -a -G lpadmin purism

Then log out or reboot the phone. Once this is done, you should have admin access to the CUPS configuration page on port 631.



That returned:
usermod: Permission denied.
usermod: cannot lock /etc/passw; try again later.

Ah yeah, should be

sudo usermod -a -G lpadmin purism

of course. My bad.


Sounds sensible. The last times I had to set up a printer on PureOS I ended up creating a root password (sudo passwd) to get it to work quickly.
And I just thought… configuring a printer should work out of the box, without much research and dark knowledge :wink:

1 Like

Makes sense. If I were more adept with terminal commands, I could have guessed it. Anyway, that did the trick! The app found my network printer right away, chose recommended driver and settings for me, no username/password required.
Trying to print a test page right now, but getting some issues (not unusual with this printer). I’ll keep trying to print.

Exciting! Thanks for the help.

Edit: Although it has found my printer, it still says it’s not connected, and I get a message about missing software, which may be proprietary and therefore not found in debian repo. I’ll keep researching the issue, but this is definitely a great start. Almost there!

1 Like

yes sorry I’ve checked if I have lpadmin perms and I didn’t (so I’ve skipped that), but I have wheel and [my] cups has implicit sysadmin permissions granted.

1 Like

even when i get my L5 i’m not connecting it to my laser-scanner-printer … simply using the touch-screen and the usb-port on the printer should be enough to get me the basics …

that’ll change when printers become open/free(d) but until then i don’t advise keeping them connected to the internet if you don’t know what to close and what to keep open … i don’t yet so i keep it off the networks in total isolation :wink:

You don’t need to keep it connected to internet. Mine lives in ring-fenced DMZ (together with other IoT) and I can still print to it over wifi.


mine’s an older xerox and doesn’t have WiFi :stuck_out_tongue:

It doesn’t need to have wifi, ethernet is sufficient, otherwise USB hub connected to [openwrt] router with cups running there

1 Like

Brother also often provides PPD files if the distribution doesn’t have specific definitions for that model (but I’d ensure you have installed all the various cups PPD files first). Having the right PPD in play means your system knows about all the capabilities of the printer (color/b&w, duplex, different paper trays, etc) and your printer software can then also be aware of them.

I’ve even seen Brother distribute them as .debs in the past but who knows what versions of Debian/Ubuntu they would actually work under.

1 Like

@Kyle_Rankin, yes, Brother is very good about that, which is way cool. I could probably go to for a Brother-specific solution, too.

I installed cups. I was unclear if there was something else cups-related that I needed. If you or anyone has a suggestion, I’ll give it a try. Otherwise I’ll eventually get around to installing the file from Brother’s website.

Printing from the L5 is not something I necessarily need right now, but it’s a neat capability.

my printer supports ipp so I used that to avoid downloading ppds. But vendor (epson) does provide them and I have downloaded them anyway (just in case, didn’t have to use). ipp printing works without them, at least fro libreoffice

1 Like

Since there is a ‘Printers’ section in Settings, I thought it would be easy to set up a printer nowadays. But there I get a message saying ‘Sorry! The system printing service doesn’t seem to be available.’

What does that mean?