Problem booting PureOS

Hi, I first want to say that I’ve received my Librem 13, and am so far quite satisfied with it; however, i have some significant issues with Pure OS.

First, when I tried to use the graphical installer after booting into the Live USB, it said the installation was successful, but the OS would not later boot. Then, I installed it using the latest snapshot (7/8/17) with the text installer, and it said that the kernel modules were missing, and therefore the install would probably fail. Lastly, I reverted to the 6/2/17 image, and it allowed me to install it and boot, but then I had two issues:

  1. When I tried to use GNOME Classic, the Applications menu at the top was missing; I could only see the Places menu.
  2. When I tried to use the regular GNOME DE, and tried to update the OS, I got an error that it could not locate the repository. During installation, I added the only mirror I could (Germany), so I thought that it should work.

Right now, I’m using Debian 9, as I have been unable to get Pure OS working. Any help you could provide would be greatly appreciated. Thanks!


I installed yesterday using this image and everything went okay. Did you perhaps try encrypted install? It is currently broken in Calamares installer.

We already know this: We’re investigating.

This was fixed in latest images AFAIK, which you didn’t manage to install.

Thanks for reporting all this. Unfortunately, I cannot give you any advice other than try Calamares Live install again, using the latest image. PureOS and its live ISO image is having some issues currently, but we are working on it. You can track some of the bugs on our tracker.

1 Like

@ezs777 You can also try older ISO image, but more recent than 6/2/17, check here:

1 Like

So, tried to boot the Live image of the latest version, and it it wouldn’t even load the OS; it go to the “Pure OS” logo screen, but then the screen turned off, and it just hanged.

I also tried the 6/2 image, and I could install it, but there were still several issues:

  1. The same thing with the Applications menu missing from the top in GNOME Classic
  2. Some applications wouldn’t even open (e.g., Software and Updates, Synaptic Package Manager)
  3. I tried to go to several website (e.g.,,, and PureBrowser never actually did aything after I hit enter.

All these happened after I applied all updates: sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade.

1 Like

That’s probably upstream bug, I’ll see if there’s any workaround.

Synaptic is not yet ported to wayland.

This is a known bug, we are working to fix PureBrowser. Meanwhile, you can use this workaround:

  • open PureBrowser
  • type about:config in the address field and hit ENTER
  • click on the YES when warning prompt comes out
  • in the search field type: security.ssl.enable_alpn
  • set the value of “security.ssl.enable_alpn” string to false

If all work prety well with debian 9, why not to stick with it ?

1 Like

I tried using the latest snapshot, and the Live USB still wouldn’t boot; what issues have been fixed in that snapshot?

Did you check sha256 hashes to see if the iso file is downloaded without problems?
How did you “burn” PureOS ISO image to your USB drive? Instructions for this are here (GUI) and here (command line).

I checked the sha256 hashes, and they match. I used the gnome-disk-utility to burn the ISO to the USB drive, and every other ISO that I have burned using this method works just fine.

To be sure, let’s first check:

  • What kind of SSD this is: are your partitions listed as /dev/sda*, or /dev/nvme0n* ?
  • What is the exact coreboot version? You can check this by doing sudo apt-get install hardinfo (or you can just search “hardinfo” in the GNOME Software center application), launching that graphical application as root, then navigating to the “Devices > DMI” section to see the version number and build date.
1 Like

My partitions are listed as /dev/sdX; here is my version of Coreboot (according to hardinfo):
Date : 06/23/2017
Vendor : coreboot
Version : 4.6-a86d1b-Purism-2
Name : Librem 13 v2
Vendor : Purism

Also, with the latest image, I still get the “Kernel modules not found” error.

A known issue. I’m trying other images now to find one without this error.

According to, it is resolved, although I am experiencing the same problem with the iso I downloaded from the downloads page. I have a 13 v2. Are there any ETA on when a working ISO will be up for download?

With the latest image the problem “Kernel modules not found” issue is solved.

1 Like