Problem installing PureOS 10 in 5800H

I tried to install PureOS 10 on my laptop which has a Ryzen 5800H and grub gives an error “no suitable video mode found”. I already tried to install Ubuntu just to test and it works perfectly. After a search I saw that maybe a firmware of kernel is needed but I dont have any idea. Can you please advice me on what to do ? My laptop is Xiaomi MI Notebook 2021

I tried this but with no luck

  1. <- download super grub disk, burn it to separate drive
  2. use pureos live (not installer media) on second drive
  3. boot super-grub2-disk
  4. put pureos live media to usb, and select detect grub.cfg
  5. boot pureos -> when I boot I get initramfs console…
  6. you will get commandline as pureos will not able to start wayland/Xorg
  7. nano /etc/apt/sources.list , add line:
    deb bullseye non-free
  8. apt update
  9. apt install firmware-amd-graphics
  10. service gdm restart

Are there Linux drivers for your graphics card that are not proprietary? Ubuntu will ship with proprietary graphics drivers while PureOS will not.

1 Like

Based on this, yes.

I’m having the same problem. I’m not good with Linux. I’m running an ASUS N4020

I haven’t tried everything you have. I’m actually getting to that point with a different installer. The one suggested by purism makes the flash drive invisible to the PC

I suppose no support ?