Problem reinstalling PureOS and partitions

I am trying to reinstall PureOS, as every time I reboot I get a message that my checksums have changed, but I don’t know why they would have (no updates or anything). Also, I find the disk encryption annoying and excessive for my purposes.

So, I am OK with doing a fresh install to start all new. I have made it to the Calamares program to install PureOS. The problem is that when I get to the partition page, no matter what option I select, the “next” box is always greyed off. I have two SSDs (original in my Librem 13 V4). I selected the bigger 1 TB drive for the Storage Device and the Bootloader Location as well. And I unchecked the encryption option.

Any ideas why I can’t progress?

Thank you.

Linux Mint perhaps? Hopefully that will work ok with the Purism hardware, as I’m stuck. I can’t even get Proton VPN to work with Purism, but with a couple clicks it’s good to go on Mint. Can’t get Trezor desktop either. So many battles and such a steep learning curve with PureOS, I don’t think I’m ready still after three years. Everything I try to do fails and I come running back to the forums. It’s getting really old.

Unless you also have a Librem 5 and are particularly keen on convergence, really it’s your computer and you are free to run whatever operating system you want, even (*cough*) Microsoft Windows.

Possibly it is getting confused by what is already there / trying to stop you making a horrible mistake. There may be merit in doing a live boot and then using gparted to persuade it that there are no partitions on the disk at all i.e. blow everything away before attempting to install an operating system.

Obviously in that case be really sure that you know what you are blowing away and that you either don’t need it or have it appropriately backed up.

So does that mean you are using Pureboot as the firmware? If so, a partial approach to making things less “excessive” would be to change that over to Coreboot. You should be able to change the firmware without any change to the PureOS installation.

(Realistically, you can’t easily get rid of disk encryption. You can of course easily change the encryption slot passphrase to something trivial - if the annoyance is having to enter a long, complicated encryption passphrase every time you boot.)

1 Like

OK, so the status in case anyone else goes down this path-

I wanted to skip the disk encryption on the partition page. I selected to erase the entire disk as I’m starting fresh. However, you cannot move to the next page unless you enter an encryption password. I tried to do a manual partition but the options that came to me were different from the how-to guide, and I don’t have the skills to figure it out.

Purism support emailed me (yay!) And walked me through the process. This time I kind of gave up and went ahead with erasing the whole disk, and just entered a crappy password instead of the beast I had before. After doing that it was pretty straightforward but there were still a few options that came up so having Purism support saved me from repeatedly trying the process until I chose the right options by fluke.

Maybe I’ll look into switching over to coreboot, then trying Mint. I put mint on a beater Chromebook and the main things I want to do just “work”. Clicky clicky and follow the instructions, and bam, done. I tried to install ProtonVPN- took about 30-60 seconds on the Chromebook. When I follow the instructions and try it on my Librem 13, I end up with an error saying it can’t find the file. I’m in the right folder, so I don’t know what I’m doing wrong. Probably a simple solution but its really hard to run PureOS without a strong Linux background. And it gets tiring running to the community with every issue. I think I can use Mint functionally, and also be involved in Linux/terminal as I wish to do some tasks and get my feet wet.

The next scary step is switching over to coreboot before attempting a Mint install. Lots of research to do first.