Problem with battery indicator


I have a problem with the battery indicator on my Librem 5. Today I used i after some time and I recognized that the battery indicator icon shows a questionmark and 0%. So I restarted the phone and the battery indicator was back to normal. After another reboot (due to updates) the battery indicator is back to 0%, another reboot does not brought it back…

Running this command:

cat /sys/class/power_supply/max170xx_battery/capacity

only returns “No such file or directory”. Generally the folder is empty, normally I would see information about the battery, charger, … here.

Thanks in advance for any help, much appreciated

Anything relevant coming from upower -d?

1 Like

Not at all. It does not detect a battery…

power supply: no
on-battery: no

I also reflashed the phone from the latest image today, but battery problem stays the same. Strange thing is that it worked after one reboot without any problems…

I have experienced this problem as well. This happened multiple times with me that the phone, mysteriously, seems to forget that there is a battery. I had to remove the battery and put it back to make it work. Not sure what is going on.

Yeah, indeed very mysterious… I already tried to remove the battery because I had this problem in the past, but other than past it did not worked today.