Pshyco-chat is crazy

Worked before just fine. Did someone fix it?

If I open Chat, it opens to the last person I was texting w/. Chat no longer goes to Main Screen CHAT.
If I go the long way around, and open Contacts, then want to send text to Joe, and click “Joe” it opens “Janes” folder.

I am smack surrounded by a wildfire. The kids running the emergency update system are making big careless mistakes so we are all using texts to get info on evac or not. And Chat goes into dumb mode.

Just what I needed from this - device, a system that send the right text to the wrong person, can’t receive any text now, they error out.
Totally powered off, and rebooted.

Is there a open source peer test safe chat that works?

This is time sensitive due to fires.
Thanks ~s

Sounds like you are in British Columbia too. I literally smell the smoke outside my house.

I would just preemptively evacuate. If you sense danger, you should simply trust your instincts.

1 Like

I haven’t experienced that here. What kind of messages are you sending? By default, the Librem5 Chats app is sending regular SMS/MMS texts via your phone company’s network. You also have the option of creating accounts that use an XMPP system or the Matrix/Riot network (hint: you would have set those up manually).

There have been several updates in recent months, so making sure you’re up-to-date is always a good thing. The next thing I would recommend is what you already did: Restart the device and see if the issue persists. There could be overload problems with your phone company’s network if there is a large fire nearby.

1 Like

Generic default SMS/MMS and as I said, it was working before. I’ve had this happen before and went back to the old way and used a landline to get through. After a few days of ignoring it, I found things were working. If I open a person in Chat app, it opened that person, not another just above or below, and I’m quite capable of clicking the centre of the icons. . Fire has squat to do with it. Unless the L5 was in the fire. :slight_smile:

UPDATE though, that now when I clink on Joe, I get Joe for a split second and then Janes last post shows up… I cannot close it, or edit it or set fire to it.

At first, I thought was due to the tap being psychotic. Don’t even have to tap anything and something will open… That’s why I just use it as a computer w/ keyboard, mouse and monitor. I still feel the problem lay with the sensors in the arena. Either the map is out, or bleeds over - IMO.

I’ll just have to shop around, test for privacy etcetera, for a working non-beta approved chat system.

Thanks FCGreg for your help,

Well have you can try socio-chat but results are less premeditated. Psycho-chat was prorgammed that way, socio-chat learned its behavior, and must have used AI.

I read their ToS:

11.5. Privacy. Your privacy is very important to us. You acknowledge and agree that your use of the Services, including information transmitted to or stored by Socio Chat, is governed by our privacy policy located at ______________

Located at blank?

Too, I blocked 17 “trackers”, the polite term for stalkers.
They want money. I already pay my ISP. I know, not same thing. SC is just another middle $ collector.
Thanks any way Tracy.

It was just a play on the endings between psycho-“path” and socio-“path” and substituting the endings with “-chat”, nothing more.


@Sharon For testing or when experiencing chat problems you could also sent and receive SMS messages using ‘Modem Manager Gui’. Checked that today (did sent a SMS to myself and it worked).
You need to know the phonenumber of the receiving party, since ‘Modem Manager Gui’ does not have the ability to use the contact database.
EDIT: I just learned that ‘Modem Manager Gui’ does have the ability to use the contact database.

I hope you are safe and sound with all these wildfires.

That is exactly what should not happen in emergency situations. Could you (when things are calmer around your place) do a video of what happens and report the chatty version.

For the mean time I’ve opened Starting chatty opens the last conversation (#829) · Issues · Librem5 / chatty · GitLab so the chatty maintainers are at least aware.



I will give it a try later today - thanks.
I’m going try to put a video together today as to what is happening, that way, once I learn how to video, and stuff, everything will work right again :upside_down_face:

I will try. Now I have excuse not to dust/vacuum today :slight_smile:

1 Like

OK, I hope this will be a (temporally) workaround for your chatty issues.

I got everything opened up and ready to go and looked at what I’d be videoing, User name, and contents of each Msg. I don’t care, but a couple people on the Gui would, and are bigger than me. :face_with_spiral_eyes:
I will try to explain: (the details are here for anyone searching with same issue.)

Assume there are 6 people in my Chat list (talk about Contacts l8tr).

  1. They are Tom, Dick, Harry Jane, & Spot (remember Spot?) OK, 5 then.
  2. There are 5 vertical circular Icons each with a letter in them, in the order I give above in #1.
  3. I want to send a text to Tom so I click dead-centre inside the circle for Tom and Dick opens up, blinks away and the last text to Jane opened. And anyone else I click on, opens Janes last msg.

I’m checking the Internet now on what it is, where to get it and how to install and use it. Now I just need to read it. Learning. I will report back w/ results in a day or 2.

I did experience something strange like this once.

Tapping on the 3rd or 4th row in chats, for example, would open the chat from the second row. Tapping the > to send a message brought me back to the messages list.

Other apps were behaving fine at the time. Rebooting the phone fixed it and I have not experienced this since.

Noted same here. I had rebooted the phone 3 times. After the 3rd, all seems well for Chat. I will careful and click send only checking destination first. Don’t want Tom reading something intended for Harry :face_with_open_eyes_and_hand_over_mouth:
I won’t tag it as a solution. I think a solution is fixing whatever made it have a hissy fit. If one isn’t paying close attention, misdirected texts, and attachments could pose problems.

Thanks for the heads up,

One question: Has your phone been reflashed ever?
(I don’t remember earlier posts, please forgive me if this question is not applicable)

1 Like

Not that I am aware of. In short, it hasn’t been re-flashed ever.

Perhaps it is something that should be done. Might help with the tap/slide/swipe issue. Like waking up on a Monday morning - hate to do it.


Here are instructions to reflash the Librem 5 with a new image. I suggest backing up any important files first before doing so.

1 Like

Easy said if I spoke the language. I only know English, the real version.

I don’t know how to “boot” the L5 via the thumb/stick/USB/drive Live or Dead.

What is a “git” and will it be on the thing I stick into the L5?

How does one “mirroring the repository”? Whose repository? Got a street or web place?

If it means going to some nerd site to get a file in order to get Pure loaded in order to fix the program, then I need a afternoon to spend reading and deciphering all the how-to above. And I paid to do this.

Geezus - why are we to learn all this? Make a note on the sales pitch page please that it’s a required thing to be a seasoned nerd.


I can only start to translate into English but …

In order to reflash (install from scratch) the Librem 5 you need a working other computer that runs Linux, typically a regular desktop or laptop. It is on that other computer that you

  • install the git package - this step is easy sudo apt install git
  • clone the repository
  • install the uuu command - will depend on the exact distro and version that you are running on the other computer
  • run a script, and
  • which you connect your Librem 5 to via a USB cable (using the specific instructions for doing so).

The directions for that second step (and everything else) are in the link that was posted above: Reflashing the Phone

That tells you how to clone the repository, whose repository it is (it’s Purism’s repository), what the address (URL) of the repository is.

Yes, it is more complicated than it would ideally be. There are reasons for that but going into those reasons would make things even more complicated and doesn’t really get you from here to there.

While the procedure is complicated, it is worthwhile mastering it. For any computer, you want to master:

  • I’ve got things set up nicely, how do I image the disk drive?
  • Oops, I just broke my computer, how do I restore the disk drive from that image that I previously made?
  • OK, even that didn’t (or can’t) fix what’s broken, so how do I install from scratch?

To do these things on the Librem 5 will require the kind of steps discussed in this post. In particular, the third option (“OK, even that didn’t fix what’s broken, so how do I install from scratch?”) is what is being specifically discussed.

And I would draw your attention to: I suggest backing up any important files first before doing so.

(This is talking about any important files on the Librem 5. Before you wipe everything out on the Librem 5 and install from scratch.)

1 Like