PureBoot beta-13 released!

PureBoot beta-13

2020-07-29

  • Rebased on HEADS upstream master branch (1d6460a3)
  • Integrated Librem Mini into main Pureboot branch
  • Added automatic booting of default boot target when Librem Key authentication successful
  • Added System Info menu option
  • Added labels to USB devices/partitions when listing for selection
  • Implemented line wrapping for long messages in dialog boxes
  • Fixed crashing when selecting TPM menu functions on a non-TPM device
  • Added fix/workaround for booting current release Arch ISOs
  • Added framebuffer mode detection fix when booting, which fixes issues booting Debian 10 ISOs among others (thx to @floppus)
  • Updated CPU microcodes for all SKL/KBL devices (as below)
  • Improved handling of mounting/unmounting USB devices
  • Updated Pureboot linux kernel to 4.19.90 (was 4.14.62)
  • Fixed factory reset function for distros using BLS type grub configs
    • Addresses issue of oem factory reset failing on a Fedora 31+ install
  • Fixed issue with setting correct index for default boot target after sorting entries
    • Addresses issue of continual ‘List of boot entries has changed’ error

Update via the Purism coreboot utility script:

(which also has a fair number of improvements/fixes itself)

cheers,
Matt

7 Likes

when will the Librem mini WITH the beta-13 PureBoot be delivered ?

1 Like

Hehe. Pure!=libre

not sure what you mean. Now that it’s released, all future orders should be loaded with that version, given a day or two lag time for the factory to update their images

1 Like

so that means that the only delays can be caused by a national-border lockdown :mask: just what we need …

Hello @MrChromebox - just to avoid confusion, is this a stable release?
I am asking because of that “beta” word but at the same time you mention future orders would have it loaded, so I expect this is a stable release?

Thanks for your clarifications

yes, all Pureboot releases so far have carried the beta tag. Not sure what the threshold is for a 1.0 release, something I need to bring up internally

2 Likes

thanks! I deployed it last night and everything is working great.

One observation of a change that wasn’t to prominent in the announcement. Now, in the boot process once the Librem Key is verifies the boot system integrity it automatically progresses to the LUKS pwd verification. So, no boot menu appears. This is nice, and I did read this somewhere, but I didn’t pick up on it right away until I was trying to boot from USB to test a Tails installation. Not a big deal, I just rebooted without the LK and then I got the boot menu options.

I’ve been wanting to try other OS’s but was having difficulty getting past the boot process so I’m hoping beta-13 will resolve my issues.

thanks again1

bullet point #3 in the changelog above :wink:

Thanks @MrChromebox!

i was able to install Fedora 32 using the new PureBoot beta-13! so I was glad about that. BUT, I can’t get the LK to work on it. Meaning, issuing gpg --card-status says that no card is detected? And there doesn’t seem to be a scdaemon install for Fedora? that is only for Debian? it does look like gpg and gpg2 have secure card functionality built into it, but i can’t get it to work with LK?

I’m having some problems with LK where i need to unblock LK, reset my PIN, etc. But, can’t do any of that.

Any ideas?

do you mean from within Fedora? It’s possible that the USB ID for the current Librem Key isn’t being recognized, but I’d have to test here and see if that’s the case

from Fedora, or from the PureBoot recovery console?

Yeah, from in Fedora itself. i can give a screen output in a little bit if you need it.

From Fedora. I didn’t think it was possible from PureBoot recovery console? or i didn’t think of trying. I’ll give that a try.

Thanks!

worked here for me with both old/new (US) Librem Keys. Did have to use sudo though.

Good point! I did not. I’ll try that and see if it works. Thx!

Nah, that didn’t work for me either. here is the message I get:

gpg: selecting card failed: No such device
gpg: OpenPGP card not available: No such device

nevermind. I figured out the problem. sudo gpg --card-status works if I don’t have the KDE Plasma Workspaces installed. I have been testing it out, so I had it installed, but i was having other issues with the LK, so I uninstalled the group. Then when I rebooted, and tried to sudo gpg --card-status it worked?! So, something with KDE Plasma Workspaces was interfering with reading the LK.