Pureboot USB boot with corrupted NVMe?

I am attempting to create a fresh installation of PureOS via live USB. I am using a Samsung NVMe disk which I tried to overwrite from within the live environment with Calamares. I followed the advanced instructions here https://tracker.pureos.net/w/installation_guide/live_system_installation/ to create partitions manually although I set LUKS encryption on the data and root partitions (maybe a mistake to do this on root?). The installer crashed and after restart I can’t boot back into the live USB. Pureboot GUI shows an error ‘cannot mount /boot’ but shows no option to boot from USB, I tried with PureOS and Tails USB but neither is recognized in GUI. I have access to the recovery shell. USB drives don’t show up with fdisk -l or ls /dev, I am not sure what to do next. Is there any way to get back to the live environment short of taking the computer apart and physically removing the NVMe drive? Once I get back into the live environment should I encrypt only the /home partition? Thank you for any assistance.


Edit: I found part of the problem. I made an error with the custom partition table, the boot loader option at the bottom was checked and I suspect it tried to write the bootloader to the fully allocated disk, with fdisk there was about a gb more sectors allocated than physical space. I reformatted the nvme disk with fdisk which corrected the partition table but Pureboot (beta 11 on L13v4) still does not boot from usb or even seem to recognize any sdb devices, I tried both a 2.0 and 3.0 usb stick. I am still hoping there is a way to get back into PureOS without taking the drives out, any help is appreciated.

if it’s an UEFI-bios motherboard then PureOS is not a good option …

Thank you for replying but I am using Purism hardware, I think the problem is with Pureboot, not PureOS. I was able to resolve this by removing the NVMe drive, I think the problem was between the Samsung drive and Pureboot, once the drive was removed I got the same error message but instead of the recovery shell I could get to the main Heads menu and the live USB. I am not sure if this issue is specific to Samsung drives or maybe a bug with Pureboot and NVMe or GPT. I flashed coreboot and no further issues installing to NVMe from USB.

As a side note about the instruction page linked above I would be interested to see a section on how to do LUKS with the custom partitioning, I tried once which wouldn’t boot and a second time I got it to boot once but after updating the software it broke so I am back on the standard MBR option for now.

@MrChromebox :point_up:

I faced similar problem today – I attempted to install OS and marked /boot to be encrypted with LUKS. Ended up in the same spot, you did – PureBoot was complaining, that it can’t mount /root and was not offering me to boot from USB. Found a way around it without removing the disk. When you go to recovery shell, try executing /bin/usb-init – worked for me. This basically brought up PureBoot’s USB boot menu. And I went from there to run PureOS live and installed with Calamares without encrypting /boot this time around.

1 Like

/boot should not be encrypted … nor /efi for our Empire loving users …