PureMap dont registrate GPS

PureMap dont find GPS. I have seen there are others with the same problem and they solved it. I am not very good at the terminal so I wonder if someone have at step by step to fix the issue.

1 Like

Used to work for me as well, but now it only updates and uses approximate location every 5 or so miles. Typically once you turn it on you leave it in clear site of sky for 5 minutes (without letting the phone sleep) and it would previously find a lock on my location at which point you can use it to navigate.

Probably a bug in gnss-share, for me the service is running and it picks up satellites etc. Not sure what the issue is.

I get this message:
*Starting lookup service…
*Failed to open /etc/geoclue/conf.d/: Error opening directory “/etc/geoclue/conf .d/”: Noe such file or filecatalog

you can always try to install it:

“sudo apt install geoclude-2.0”

“sudo systemctl stop geoclue”
“sudo systemctl enable geoclue”
“sudo systemctl start geoclue”

Or re-install

Thanks I will try :slight_smile:

Nope did not work it dont find it on the system and dont find the package, so sur I must write somthing wrong because when writing this; dpkg -l | grep geoclue
I se that I am running geoclude 2.7
Any tip on this?

If you go through older thread

then there are documented Librem 5 GNSS hardware troubles (promised to be mostly solved in later production batches) and related debugging of low level serial port connection to GNSS Teseo-LIV3 GNSS Module, then its support through gnss-share daemon and geoclue-2.0 with description how to debug and configure individual components. In general, I believe and have even checked actual Pure OS /etc setups when upgrading over my modified version and I think that defaults of current installs should setup all necessary out of the box correctly. It seems that the connection to GNSS Teseo-LIV3 GNSS Module works to others without problems too… Antenna RF path and strength of the signal are another topic.

I tried the PureMap today after reinstall, and firstly it was like last time, then I was thinking to just let it be on. I was parking outside the shop waiting for my wife coming out and suddenly it worked :slight_smile: I already set up the destination so then I could use it :slight_smile: