PureMaps on L5 - Geoclue denies access

Recently I received my L5 and now I’m trying to use GPS in PureMaps (flatpak’d version), but it does not work, and there is pretty self-descriptive message in the application log:

qt.positioning.geoclue2patched: Unable to start the client: "org.freedesktop.DBus.Error.AccessDenied": "Geolocation disabled for UID 1000"

gdbus introspect shows that Geoclue receives the requests and returns an error to PureMaps, i. e. there is an access control on the Geoclue side. After some research I found that the access control is configured in geoclue.conf, so I tried two things:

  1. Add PureMaps to agents whitelist.
  2. Add PureMaps to list of applications with allowed=true.

However, the issue persists. I also tried geoclue’s where-am-i tool on behalf of UID 1000 (at the host system, without any containerization), and it receives similar denial from Geoclue, even though geoclue-demo-agent is in the whitelist of agents by default.

What do I miss? Is there anything else that should be configured to allow PureMaps access Geoclue?

P.S.: I’ve ensured that both GNSS module and gnss-share work correctly; also I shut Geoclue service down after each reconfiguration so it did not use old settings.

1 Like

Sounds like you have disabled location services on your phone. Check it in Settings -> Privacy -> Location Services.

Access control in geoclue.conf is completely unrelated, and phosh is already a geoclue agent so you shouldn’t try to use the demo one either.

1 Like

Thanks @dos, that was the obvious missing part! :slight_smile: