PureOS 9 Installation fails - FADT indicates ASPM unsupported

Hi everyone,
Attempting to install PureOS 9 on a legacy laptop (ASUS, has never had PureOS installed on it) on which an existing Ubuntu 16.04 LTS is running. I managed to create the boot usb with PureOS 9 iso file, starts well, but when should show the INSTALLATION screen, only the BusyBox shows (initramfs struff).

When trying to run the PureOS 9 iso file under the “failsafe” mode, I have more logs; see attached failsafe screenshots, and it seems an issue with the “FADT” / “ASPM”. No idea what it could be.

Thank for the help.

I’m not certain about those specific errors, but in general, you will not be able to install PureOS on most hardware. It doesn’t contain proprietary drivers, which most hardware requires.

The Librem laptops have components specifically chosen to work with open-source drivers. I would just stick with Ubuntu or Debian (with the non-free repos added, for the hardware support) if you are using a non-Librem computer.

Thanks for the tip.
I just managed to install TRISQUEL on the same computer, so I thought maybe PureOS would have worked. But ok, got it.

Huh, well, ok then, if Trisquel worked, then I am surprised PureOS is having trouble. I don’t believe PureOS supports UEFI, so maybe that is the issue (though I don’t think I would expect Trisquel to work with UEFI either, but maybe I am wrong).

Have you checked your BIOS/UEFI settings to enable Legacy Mode?

Absolutely sir. I have :

  1. Removed BIOS secure boot
  2. Activated CSM
  3. Activated PXE OpRom (this controls the Legacy PXE OpRom)
  4. When trying again the PureOS LIVE, I have run the Advanced options > Hardware Detection Tool. I saw the “ACPI” tab (when you look at the logs I have attached previously, there are mentions on ‘acpi’ stuff), seems ok (see attached picture) but I definitely have no clue about all the errors in my first image attached to this topic.

I am currently performing another option in the Advanced options > Memory checks, just to be sure. But that will not solve anything.

Well, I am afraid I really don’t know then.

What model laptop is it?

ASUS N56VZ. Intel Core i7-3630QM 2.40 GHz, 16 GB ram, etc.

Do you know if there is a possibility to go through the logs ? I mean when I end up on the BusyBox, can I visualize again these logs in a file, or using vi or any other tool ? It would be easier at least to go through all the lines, and maybe spot the cause of all the failure… So far I only managed to take pictures, not easy.

I am not sure.

You might be able to try Ctrl+Alt+F2 (try all the function keys if F2 doesn’t do anything) to see if that takes you to a terminal. If you do get to a terminal and are prompted for login info, try

username: pureos
password: live

From there, you presumably should be able to use tools like vi to check for logs (I think in /var/log).

I imagine you have the Nvidia card as listed in the specs? Since Trisquel worked, I don’t think this will actually solve anything, but you could try adding the nomodeset boot parameter before attempting the install. When at the first boot menu that lets you choose to try the live os or install or whatever, I think you should be able to press the “E” key to edit the config. You can add nomodeset after the quiet splash or whatever it is there (I’m going from memory here, so there could be some mistakes).

I’ve had tons of issues with Nvidia cards causing problems unless I first booted into the live OS with the nomodeset parameter.

Thanks for the answer. I have done the following

  1. login using pureos/live does not work :

login : pureos
password : live

  1. I am actually able to go through the “BusyBox” Linux, and see /var but no /var/logs. I ony see casper.log, which looks like this :

It says the FAT-fs has IO charset ascii not found… Could it be related to FAT instead of FAT-32 USB (or vice-versa) ? ==> I WILL TRY TO CREATE AGAIN THE USB KEY with FAT instead of FAT-32.

  1. I have tried the nomodeset : it changed the wait cursor just, but ended with the same result.

I am afraid I am out of ideas. Sorry I couldn’t be more helpful

you were very helpful :wink: Thank you.
I will continue to investigate.

If helps, under your laptop BIOS settings did you UnLock USB Interface Security (all of them)? How about taking another look, change/save with F10 again Boot Option #1 (and #2) under Boot Option Priorities. Perhaps to try to use first USB port on the left side (charging one) as your first choice and only one (if I saw: “USB hub found”) … additional useful (this case scenario related) reading is here.

I managed to make it work.

    As I said previously “I WILL TRY TO CREATE AGAIN THE USB KEY with FAT instead of FAT-32.”. I actually formatted the USB key not with FAT, but NTFS.
    Then created the PureOS LIVE with balenaEtcher : and it worked.

My next step is to install the non-free (beeuuh… but I don’t have any choice unfortunately) WIFI driver of my laptop to have a full internet connectivity, and that’s it.

Thank you all for your time.


PureOS-10-Byzantium(testing) is working well for me > https://downloads.pureos.net/byzantium/gnome/2020-11-20/

9 is too old and Byzantium should enter feature freeze in a couple months so it’s a great time to get testing if you can …

from the PureOS 9 GNOME environment you can burn the PureOS 10 devel .iso image with the ‘Disk’ app and select from the top-right menu > drop-down-list > ‘restore disk image’

Hi, Thank you for the proposal. So let’s make it the following way :

  • let me finish the installation of PureOS 9 stable version, with the wifi working, and do a quick check on all the functionalities I need : Average usage (internet / office / pdf / movies) + developments (Java, Web development / Php+Javscript, JBOSS / other common middleware).
  • once 9 functional, I will install the PureOS 10 DEV following your link.

Finally :

  1. Remind me just where should I post any bugs/issues if I find any ? forums.puri.sm or on tracker.pureos.net ?
  2. Is there a clear PureOs lifecycle/support roadmap regarding the version ? You know, as they have on Ubuntu for instance…

PureOS 10 development follows upstream Debian 11 Bullseye (will become new stable 11 soon we hope).

Debian is NOT Ubuntu. Ubuntu is based on Debian but they do newer packages and stuff. Debian is STABLE and that’s why i generally don’t hesitate to recommend people to try out the testing versions that are based on Debian-Testing. PureOS Byzantium is no exception to this.

if you want to post/report stuff the official way you are encouraged to use Purism’s Git-Lab instance. i’m not a Purism employee and that’s why i jump in on the forums.

Perfectly understood. Thank you for the tips. I will install the PureOS 10 then. Cheers.

Etcher formats the USB drive when it flashes the iso to it, so I suspect the solution was using etcher versus whatever it was you did the first time.

1 Like

Once again, and for the record if anyone encounter the same issue as I have : I used balenaEtcher since the beginning, but still it did not work. I then went on my Windows, right-click on my usb, format it in NTFS, then burned with balenaEtcher again.