PureOS crashes on my laptop and doesn't load on my desktop

Hi, im testing PureOS on a brand new Samsung T7 2TB SSD drive.

I have booted it live on a CD on my desktop, works, but after installing it on the SSD, the GUI doesn’t load, I just get a blinking underscore.

I plugged it into my old i5 laptop from 2011. It boots fine. I’ve updated it, tested things around, then I left it idle while I was on my desktop and then when I went back my laptop it had a screen full of command line stuff. I remember some I/O errors while writting a superblock or something. Then I remember “irq 19: nobody cared (try booting with the “irqpoll” option)” and at the end some watchdow error where it was stuck, and I was forced to reboot at this point.

When I tried to boot again the drive was not showing up, I was worried the drive was dead but the LED was still on. I plugged it onto my desktop, and doesn’t show up on the bios boot menu as well, but at least it shows up under disk management. After a while I try again on my laptop and it shows on the boot menu.

Anyway, it’s clear something it’s wrong. What im considering:

  1. The SSD is fautly. How do I test this?
  2. Some compatibility between PureOS and some piece of hardware
  3. Something else such as RAM. However, I reckon I ran memtest on my laptop a while ago and it was fine. Also I use my laptop daily with Windows 10 and it works fine (but this is installed in the internal HDD that came with the laptop)

The PureOS is encrypted btw, not sure if relevant.

Anyway, im considering trying some other decent distro like Pop OS which i’ve seen recommended as a non bloated distro. However I was really into the idea of using a 100% free distro, specially for running Bitcoin stuff seems interesting. The thing is, I cannot work like this. Imagine it crashes while syncing the blockchain on a full Bitcoin node and you have to re-index the entire blockchain again (which is typical in crashes).

If someone has any ideas to try I would like to hear. cheers

What graphics device? Intel integrated? nVidia? Something else?

For hassle-free Linux experience (any distro but quite likely especially PureOS) stick with Intel integrated graphics. “100% free” doesn’t sit well with proprietary graphics device drivers.

So that’s a portable drive, right? Any chance that you have a T5 to try instead (fault isolation) because I know for a fact that the T5 works well with Linux.

Also, while you don’t mention much about the computers that you are installing on, you want to avoid UEFI i.e. (legacy) BIOS only.

For fault isolation purposes you might try Ubuntu. (Even if you don’t like Ubuntu, it’s just to test whether there is a difference between it and PureOS.)

1 Like

I have a 3950X CPU so no integrated intel graphics. Then for the GPU it’s a 1660 super.

Yes T7 is portable. I don’t have T5. Btw I have now after sleeping and perhaps, perhaps its possible that the cable wasn’t fully plugged in because i made pressure on the cable (on the end that connects on the drive) and it did a “click” as if it there was a small gap not pressed fully… im testing again leaving my laptop on all day. Im gonna try to sync a Bitcoin node.

Btw, does PureOS work on a Librebooted x200? Im gonna pick up one when I can find a good deal. While it will be a lot slower, I think these laptos where the last fully free laptops. So it’s the compromise one has to do to get 0 propietary blobs in there. For now im gonna continue with the i5 laptop and see what happens. Hopefully the NSA is not spying on my node.

And btw, how can I check the log? I want to read exactly what happened.

Another crash. It says

EXT-fs error (device dm-0): __ext4_find_entry:1449: inode #828692: comm gdm-session-wr: reading directory iblock 0

Buffer I/O error on dev dm-0, logical block 0, lost sync page write
EXT4-fs (dm-0): I/O error while writing superblock

geez

Welcome to foss drivers. You’ll need to be able to sort out the nvidia and ssd drivers, which means PureOS is probably out. Unless you like digging and cobbling stuff together.

This guy got the same error on pop_os, may be related?

Yes, it is an amazing combo even and works very well.

1 Like

Well first I would like to guarantee that the SSD is not faulty.

I have tried running gsmartcontrol but SMART stuff on the disk is empty. No error logs, no available test, anything. SMART test stuff also greyed out in gnome-disks

How do test the health of the SSD then?

I was only able to run this command:

$ sudo smartctl -d scsi -H /dev/sdb

And it said SMART health status OK, as seen here:

Notice that for some reason I had to specify the disk as scsi otherwise nothing else worked.

Anyway, all other commands it doesn’t work. It runs the self-test but I cannot even print any logs or anything because it says the disk doesn’t allow for it. So im not sure what to do to check the health of the disk and discard it’s not faulty even if it’s brand new.

Btw the battery on my laptop is screwed up because if it’s not plugged it shuts down. However I use Windows every day on it with the battery plugged and I get no errors so im assuming this is not relevant? I have no other computers to test this on. I may have to install Pop OS and let the SSD run on my desktop for some hours and see if same error happens because im out of ideas.

Edit: I installer Samsung Magician which is a tool to check SSD health and clicked on SMART and there I can see the SMART stuff and all rows say OK. So the drive is OK?

OK. Fault isolation: Try a random flash drive. Sure, the performance won’t be great but you want to narrow down what will work and what won’t.

I assume this refers to encryption by the host - because the encryption features of the T7 drive itself are not supported on Linux.