PureOS first impressions

I’ve been lurking for a while around PureOS and finally got a Librem 15 to try it out with.
Being a happy Debian user, I’ve been skeptical of yet another fork, but given that Purism does so much right, I decided to give it a shot.
Here’s what happened.
gnome-initial-setup crashed the first time I clicked on the wifi i wanted to setup… but “logging out” brought the setup back up again.
The second time it finished as it should have, however it seems to have forgotten about encrypting the disk with my passphrase?
After rebooting, the laptop booted without asking for the encryption key, ugh…

Onwards to installing software I guessed… Gnome’s Software failed to install anything (with a 404).
When hitting update it said the package lists were up to date… which apparently they were not.

Knowing this is a Debian-based system, I opened a terminal and ran the venerable apt-get update && apt-get upgrade (the former giving some error which disappeared after the latter).
It said something about linux-kernel and grub… Not a good sign I thought but didn’t really bother with it.
I’m was on the happy path, right? Well, wrong.
But first I could install software and the system kept running as expected and i was quite happily playing with Gnome Boxes until I shut it down and started it up again.
It refused to boot with a cryptic cryptsetup error, saying it didn´t have a passphrase to unlock the volume. Great?
Finding no way to supply it with a passphrase and not knowing what to do in the emergency shell, I ducked the internet and found not a lot… maybe it was the new kernel which broke luks, but alas there was no old kernel to select in grub.
So all in all I was left with an encrypted volume which may or may not have been encrypted with the passphrase I chose and no way really to do anything about it.

Before and after all that I tried to install qubes from the usb stick I ordered along with the laptop.
SeaBIOS sometimes doesnt find the usb stick at all and most of the time tries booting from it but then the bootloader gets stuck somewhere. I guess the usb stick is just broken, since booting from a USB SD card reader works fine.

Well, those have been my first impressions of the Librem 15, PureOS and Qubes.
Now I am running vanilla Debian with KDE (which I’ve never really used before), lvm but no disk encryption and nothing has crashed so far.

I thought PureOS was supposed to give me kind of an opinionated Debian without non-free stuff and a well-supported happy path with full disk encryption.

Now after 2 days of lost work I wonder… why should I bother with PureOS?
Isn’t it just an opinionated Debian fork?
When there is no way to not encrypt the disk in the initial setup, shouldn’t it bloody work without breaking in such a trivial way?

I can understand that stuff breaks and sometimes you have to get into a terminal and fix it, but I tried to stay on the supported happy path as much as possible but apparently it went up in flames before i could setup the wifi. My point is, probably that shouldn’t happen.

@diabol: I’m really sorry about your experience. While I didn’t completely have an identical first impression, I too, had some issues around LUKS setup and wireless as well. I resolved them with a somewhat crude method - downloading the Pure ISO from pureos.net and installing from there. I believed at the time it was issue with the OEM image. I’m loathe to call plurality of anecdote evidence but it could merit some root cause analysis on Purism’s end. I really like Purism’s vision of free (libre) and secure computing being usable by the general public. But that means things like this get addressed.

I’ve moved onto to Qubes myself. Not because of any shortcoming on PureOS but for my professional needs. And I’m happy to report that my Librem 13v3 works just fine there.

1 Like

I can’t really speak to your experience, but I also wanted to try PureOS prior to getting the Librem 5. I was running Linux Mint so I did a bootable USB with the .iso from their website thinking I can plug and play basically. I had some issues like the install setup menu basically closing the window every time I typed in my encrypted passphrase. I thought maybe it was too long, or maybe I had to connect to WiFi first. Either way, it wasn’t as smooth as previous switches to other Linux flavors.

In the end, I used PureOS’s utility tool to delete the partitions and basically start fresh and following their manual partitioning guide and that worked like a charm. I haven’t had any issues since and I’m pleased with the OS and the aesthetic. It’s going to take time for Purism to grow obviously, but I think they’re on the right track. I don’t expect them to be like Fedora or Ubuntu. But they’ll get there and hopefully surpass expectations and more.

Lot’s to reply to in your post but if I may ask what version of the Librem 15 you’re using so we can address some of these issues?

It is the 15v3 (ordered it right before v4 was announced).
Unfortunately I can’t really say which image of PureOS it shipped with.

Thank you everybody for replying.
My first impressions with PureOS have been rather frustrating and the lack of documentation hasn’t really helped.
The hardware, btw, is just great for running a Linux distro.

Now this isn’t really part of my first impression, but I just found out that the USB Type-C port is just a USB3 port.
Which means apparently that I’m stuck with an HDMI port.
Shame on me for assuming the Type-C was there for a docking station, shame on Purism for not documenting the hardware properly.

I would like to improve on that, but frankly I don’t know where to start.
I mean there is the official wiki at https://wiki.puri.sm/hw/L15/v3 but it’s sparse and doesn’t seem to be user-editable -.-

If you to use the command line to determine the processor, that might let us know exactly which version of the Librem 15 you’re running. Below is the command line invocation to determine exact processor details;

$ cat /proc/cpuinfo

For example, doing that command on my Librem 13 produces this output (in addition to a lot of other output);

Intel(R) Core(TM) i7-6500U CPU @ 2.50GHz

My machine has a USB C port in which I insert a USB C cable that allows me to plug in a 4 port USB 3 hub into which I plug in my mouse, keyboard, audio, and even a cable to phone.

I have the same output in /proc/cpuinfo, so I do not think it’s much more exact than 15v3 now :slight_smile:

Update: I do remember that PureBrowser had Google as it’s default search engine (yuck), which struck me as odd. If there is a related bug, it could at least help narrow down the OEM image that the laptop shipped with.

I think that we’ve had DuckDuckGo as the default now for months. So I think that bug is closed. :slight_smile: