PureOS install from USB stick runs memest

I need to re-install PureOS on my Librem 13v2. I downloaded the latest iso and put it on a USB stick using “dd”. I can mount it on CentOS, and it looks fine. But apparently it is not bootable.

When the Librem 13 powers up, I press ESC to get to the boot menu. The USB stick is shown as #2. I select #2, and it runs memtest instead of booting.

Is there an extra step required to make the USB stick bootable?

Followup: I burned the ISO to a DVD and was able to install from an external drive.

What’s the secret to making a USB stick bootable? Apparently dd’ing the ISO is not sufficient.

Hi @logicprobe,

I believe this can help:

  • Insert USB drive but do not mount it: it must be unmounted.
  • Open your favorite terminal emulator and run sudo fdisk -l to check drive designations.
  • Runthe following command, replacing sdX with your USB drive designation, for example: sdc (be very careful here!)
    The sync part is important, do not ommit it!
sudo dd bs=4M if=/path/to/PureOS-2.1.iso of=/dev/sdX status=progress && sync

After dd command finishes, your drive is ready.

Hi thlb,

That is exactly what I did, I put the ISO on a USB stick using “dd” according to those instructions. It didn’t work, hence my question.

The problem was not the ISO image itself, because I burned it to a DVD and was able to install, hence my followup post.

Did the dd output mention anything specific?

Did you try to burn it with Etcher as well?

1 Like

The dd output indicated that it ran cleanly. I can mount the USB stick on a running system and see files, etc., but can’t boot from it.

I don’t have Etcher, but I do have a reliable external USB DVD drive and lots of blank DVDs. I burned the ISO to DVD and was able to install from spinning shiny disk. Problem solved, but I’m still curious.

I just had the same issue (on librem 15v3). But after I booted the coreinfo to check my coreboot version, and then tried again, then this time it worked. No idea why.

https://etcher.io/ ftw

IMO using etcher or dd is irrelevant to this issue.

Today I plugged in 2 usb sticks and tried to boot system from one of them. I had to repeat few times, because at random the boot list would not show them at all, show them but enter memtest, once it even shown one of them duplicated.

I too am having this error. As others have pointed out, it does not seem to reflect improperly iso burning (I have booted the same usb on other linux machines). Seems more like a bug in the Purism bios…