PureOS live USB boots to GRUB shell

I tried to create a USB drive from the 10.3 iso, but when I try to boot from the drive it jumps straight to a GRUB Shell without any options to boot to PureOSLive or install. I downloaded this image/sha256sum:

f4dca2a64547ca4873142418281b0c4cf38fb27df414b63425e359b8ecf869f6  ./pureos-10.3-gnome-live-20230614_amd64.iso

Post download I confirmed the image was good:

sha256sum ~/Downloads/pureos-10.3-gnome-live-20230614_amd64.iso
f4dca2a64547ca4873142418281b0c4cf38fb27df414b63425e359b8ecf869f6  /home/user/Downloads/pureos-10.3-gnome-live-20230614_amd64.iso

I then flashed the image to several different USB drives, using different tools (etcher, Gnome Disks, dd) and each time confirmed the image sha (/dev/sda is the USB device):

sudo head -c $(stat -c '%s' /home/user/Downloads/pureos-10.3-gnome-live-20230614_amd64.iso) /dev/sda | sha256sum
f4dca2a64547ca4873142418281b0c4cf38fb27df414b63425e359b8ecf869f6  -

In all cases the checksums matched, but I always end up at the grub shell. I’m running Pop_OS! 22.04. I did try running the same ISO in a VM and everything worked, it presents the PureOS install as expected. I also tried several other ISO’s from other distros just to make sure nothing was wrong with my current setup, they worked and I could run/install as expected.

Are there instructions on how to boot from the grub shell, or is something wrong with the current ISO?

1 Like

The PureOS image works fine, and all the steps you have followed should have worked. Have you tried using Ventoy?

1 Like

@mcginger Are you booting on a Librem device or something else? If you’re on a Librem, could you check what firmware version you have (sudo dmidecode -s bios-version)? It’s possible this could be firmware-related (but could also be a lot of other things too). Can you boot any other GRUB-based ISOs from any of those flash drives in the same device, like the memtest86+ GRUB image?

1 Like

Thanks @FranklyFlawless , I haven’t tried ventoy but I will and report back.

1 Like

@jonathon.hall, I’ve tried booting from two different laptops: a Thinkpad T14 and System76 Pangolin 10, both with the same grub shell results.

I didn’t try the memtest86+ image, but I was able to flash two other distros to the same USB and they both boot as expected.

1 Like

Thanks for clarifying. If you’re booting in UEFI mode, you might want to try booting in BIOS mode to see if it’s any different. I mainly focus on firmware (others focus more on OS), so I can’t help with the specifics on those devices as much :slightly_smiling_face:

1 Like