PureOS Re-Install Freezes

I etched the ISO on USB following procedure. Librem Key is in.
Selected Boot USB to start. It freezes after 4 lines of output.
Here are the 4 lines:

Loading the new kernel:
kexec -l /media/casper/vmlinuz --initrd= …(etc)…
Starting the new kernel
[ 34.2641741 kexec_core: Starting new kernel

I have a Librem Mini v2.
I verified the iso checksum and I’ve burned it onto different USB’s with the same result.
I’ve tested a different iso and it started ok (qubes).
My system, before I decided to reinstall PureOS was a new install of Qubes.
My disks are encrypted, but as I understand it, that shouldn’t prevent install (and my test of the Qubes iso seems to show that).

Thanks for the help!


I’m sorry, but I’ll need much more information to understand.

  1. Which ISO specifically are you using?
  2. What are you running for BIOS on your mini? Coreboot?
  3. How do you know disk encryption is not interfering?



Hi Jeremiah,

  1. Iso is: pureos-9.0-gnome-live_20200806-amd64.hybrid.iso
  2. Bios is PureBoot-v2-Release-17 for Mini v2. I successfully flashed it last night, but it didn’t solve the problem.
  3. I don’t actually “know”, I was assuming it’s not relevant. But now not so sure.
    I am looking into how to remove Qubes disk encryption to see what I can learn.


If you have a Librem Mini, then please try to use this image:


The Librem Mini requires PureOS 10 (a.k.a Byzantium).


Does that apply to the Mini 2 also?

Hi, sorry I was if I was not clear. Yes, it also applies to the Miniv2


Thanks, I’ll give it go.

Yay! It got to the Welcome screen for the installer. Thanks.


Yeah, The Librem Mini v2 does not actually support the latest real release of PureOS, the only one you can find to download on the site afaict. And this isn’t mentioned anywhere to people who purchase the Mini. And there’s no documentation specifically for the Mini. It all feels very weird.

I hosed my system with that byzantium install. :worried:
Feeling kicked to the side of the road so I walked away for a while.
During the install it recommends changing the partition to GPT instead of MBR. Rats!
It might have worked if I wasn’t trying to get rid of the encryption on the drive and had left the partitions alone. Wish there was a better walkthrough combining these issues.
In fact I have been writing one as I proceed (LibremKey, GPG, PureOS, Qubes, single boot/double boot) and hope to submit it if I’m successful. But for now I keep getting knocked further and further back.
Now I’m drawing a blank on what to do… hence stepping away for a bit.

For me, with PureBoot on the Mini v2, I wasn’t able to boot hardly any USB distro installer I tried. Or if it was able to boot into the installer, it couldn’t actually install the OS.

The one PureOS that worked for me was this – an older Byzantium than the one linked above, maybe it will be luckier for you, who knows:

But what DID work for me, to finally make me happy with the Mini v2: was ditching PureBoot (along with Librem Key and all that cool stuff) by flashing the regular coreboot/SeaBIOS instead. From there, it was successful at booting into any USB key I wanted. Like, I installed FreeBSD no problem, with encrypted disks. Working smoothly so far.

So I’m happy with my Mini v2 now, but man I was frustrated and wasted a lot of time on things like “Failed to start kernel” or corrupted graphics from distro installers and such, before I got there!

Not sure what your blocker is but good luck!

Messing around with Qubes, it’s early yet, but install is proceeding.
Fyi, the link above didn’t work for me, no such directory that I could find.
I’ll post if I make progress.

Ah you’re right, guess that one’s gone now. Well best of luck with Qubes :slight_smile:

The Librem Mini comes with the latest release of PureOS – PureOS 10 ‘Byzantium’. The previous version was version 9. The mini needs a newer kernel much like all recent hardware, so the mini only works with PureOS 10 and other more recent distros. It’s true that PureOS 10 is not our stable release, but it will be stable shortly, within six months and maybe sooner.

You need a recent kernel for the mini.

Thanks, that helps my understanding. And I can live with that. :slight_smile:
Fyi, with my order I also got a Qubes Install USB. It has the unstable release for Qubes (4.1.0). I’ll assume it’s for the same kernel reason.
BUT, I tried the stable release (4.0.4) and installed it successfully.

It is all working well again. Thanks to everyone for the help! :+1: