Pureos rolling release

Unless it is done for you, as happens with Ubuntu.

1 Like

I am interested in switching from Amber to Byzantium. I am wondering what the status of Byzantium is. :smiley:

In November, I see a message from @jeremiah:

Please note, this is an early release, it is meant for testing, not production.

And I see another one (regarding the ISOs):

Please note they are experimental at this point.

Just curious, will there be a point when Byzantium is more official/supported? Or will it always be more of a experimental/“do it at your own risk” type of thing?

1 Like

For what it’s worth, I’ve been running Byzantium since November and the experience hasn’t been noticeably different from running Amber, aside from newer software. Any bugs I’ve encountered have been upstream bugs with GNOME 3.34, but Amber has upstream bugs too that were fixed in newer versions of GNOME.


aye, but it’s about the AMOUNT of bugs that have ALREADY been fixed or that are reported but have not been fixed yet …

there is a method called “heat” to up-vote bugs so that the higher priority ones are fixed first … not sure if this applies to the “testing” or only for “stable” … please somebody expand here …

Thanks for reporting your experience, I’m considering switching to Byzantium now. I would love to have newer versions, and can live with a few bugs in random software, the only thing I would dread is if things completely break (like boot issues). But I guess the advantage here is that PureOS is tested on Liberem’s hardware.

Byzantium is supported, we aim to fix bugs and ensure it is up to date and secure. But because it is a rolling release it is updated frequently and that brings more instability. Amber is less frequently updated and software has had a longer testing cycle by users and in production. At some point, and this will be announced in the future, likely next year, Byzantium will become our “stable” distro. Amber will become “old stable” (or even deprecated) and we’ll have a new rolling release.


Thanks for the info, @jeremiah!

Is there an advised path forward to move from Amber to Byzantium? Knowing at some point I will want to update, would it be better/easier to do sooner, or later; or won’t make much difference? Thanks again!

What I found strange recently was that there was no riot to install on byzantium. I had to install it from the debian package manually. Isn’t that strange?

I followed the steps in Pureos rolling release to upgrade to byzantium, but get the following errors during apt full-upgrade:

Err:1 https://repo.puri.sm/pureos byzantium/main amd64 libpango-1.0-0 amd64 1.42.4-8
  404  Not Found [IP: 443]
Err:2 https://repo.puri.sm/pureos byzantium/main amd64 libpangoft2-1.0-0 amd64 1.42.4-8
  404  Not Found [IP: 443]
Err:3 https://repo.puri.sm/pureos byzantium/main amd64 libpangocairo-1.0-0 amd64 1.42.4-8
  404  Not Found [IP: 443]
Err:4 https://repo.puri.sm/pureos byzantium/main amd64 libpangoxft-1.0-0 amd64 1.42.4-8
  404  Not Found [IP: 443]
Err:5 https://repo.puri.sm/pureos byzantium/main amd64 gir1.2-pango-1.0 amd64 1.42.4-8
  404  Not Found [IP: 443]
Err:6 https://repo.puri.sm/pureos byzantium/main amd64 nautilus amd64 3.36.1-1
  404  Not Found [IP: 443]
Err:7 https://repo.puri.sm/pureos byzantium/main amd64 libnautilus-extension1a amd64 3.36.1-1
  404  Not Found [IP: 443]
Err:8 https://repo.puri.sm/pureos byzantium/main amd64 nautilus-data all 3.36.1-1
  404  Not Found [IP: 443]
Err:9 https://repo.puri.sm/pureos byzantium/main amd64 libsrtp2-1 amd64 2.3.0-3
  404  Not Found [IP: 443]
E: Failed to fetch https://repo.puri.sm/pureos/pool/main/p/pango1.0/libpango-1.0-0_1.42.4-8_amd64.deb  404  Not Found [IP: 443]
E: Failed to fetch https://repo.puri.sm/pureos/pool/main/p/pango1.0/libpangoft2-1.0-0_1.42.4-8_amd64.deb  404  Not Found [IP: 443]
E: Failed to fetch https://repo.puri.sm/pureos/pool/main/p/pango1.0/libpangocairo-1.0-0_1.42.4-8_amd64.deb  404  Not Found [IP: 443]
E: Failed to fetch https://repo.puri.sm/pureos/pool/main/p/pango1.0/libpangoxft-1.0-0_1.42.4-8_amd64.deb  404  Not Found [IP: 443]
E: Failed to fetch https://repo.puri.sm/pureos/pool/main/p/pango1.0/gir1.2-pango-1.0_1.42.4-8_amd64.deb  404  Not Found [IP: 443]
E: Failed to fetch https://repo.puri.sm/pureos/pool/main/n/nautilus/nautilus_3.36.1-1_amd64.deb  404  Not Found [IP: 443]
E: Failed to fetch https://repo.puri.sm/pureos/pool/main/n/nautilus/libnautilus-extension1a_3.36.1-1_amd64.deb  404  Not Found [IP: 443]
E: Failed to fetch https://repo.puri.sm/pureos/pool/main/n/nautilus/nautilus-data_3.36.1-1_all.deb  404  Not Found [IP: 443]
E: Failed to fetch https://repo.puri.sm/pureos/pool/main/libs/libsrtp2/libsrtp2-1_2.3.0-3_amd64.deb  404  Not Found [IP: 443]

It can’t continue after that.
Anyone have an idea?
Edit: solved

Looks like if the server was down, try again now or do ping -c1 to see if you can reach it.

1 Like

Ping works fine! FWIW it downloaded about 1500 other packages successfully Just not the ones in the error message. It looks like the package versions actually on the server mismatch the ones in the apt metadata.

FWIW it looks like this problem was solved, or solved itself. I just re-tried and was successful in upgrading amber to byzantium on my Librem15v4. First experience is that rendering and screen updates feel faster, probably due to the new Mesa graphics drivers.

Operating system: pureos Byzantium
Did an update today and after I turn on my system instead of the login screen I get
Oh no! Something has gone wrong.
A problem has occured and the system can’t recover. Please contact a system administrator.
What I do after that:
•sudo startx
• display shows
Oh no! Something has gone wrong.
A problem has occured and the system can’t recover. Please contact a system administrator.
With an option to logout below.
• I click logout.
•The XKEYBOARD keymap compiler (xkbcomp) reports:
Internal error: Could not resolve keysym XF86FullScreen
Errors from xkbcomp are not fatal to the X server
xinit: connection to the xserver lost

I have the same on a Byzantium machine in Virtualbox. Are you also running your machine in Virtualbox, or is it non-virtual? (I have no solution, sorry).

@Linuxnoob I have it even worse in Virtualbox - if I switch to another VT I only get the message

A start job is running for Hold until boot process finishes up (2min 30s / no limit)

So, I cannot even get a login prompt.

I am not using a virtual box. I am using it on a desktop.

I have the same problem. :dizzy_face: I hope someone can share a solution soon :pray:

Gnome 3.36 had broken Debian (testing) a week ago but it was solved in an update next day.
Try to update from the comand line again.

I tried updating, but it didn’t help. However, I have 8 packages being kept back:

Try sudo apt full-upgrade but don’t do it just take a picture of the output and show it here or write it down.

The problem is that Debian people update some packages to gnome 3.36 but they left some dependencies without updating but I don’t remember wich ones, maybe gir…