PureOS store unresponsive

This seems to be a common issue. The PureOS store app is very very slow to display anything.

At the moment, I am trying to check for updates. I’ve given the Librem 5 more than an hour on the update screen and it still keeps showing the spinning update circle and “this may take a while ( forever )”

Meantime I ran sudo apt update and upgrade and installed updates that way.

Any way to get PureOS store app to respond?

1 Like

You need to restart the phone

First thing I tried. No change.

Also, did a restart after doing the updates using the command line. No change.

I have the same experience. The PureOS Store is the worst. Updates come every now and then, which is ok, but I see no apps (there used to be some, after waiting for a loooong time for category views to update - some never had anything). It should be both, a showcase to best and/or most wanted apps (or alternatives), and also a way to find solutions to software needs. Now it’s just… meh, or even worse, a waste of time.

And calling it a store is not a good choice. Nothing is sold. Nothing worth buying either. For what it’s used now and what it could be,… let’s call it a warehouse or hub. Add docs and wiki and how-to’s and it would evolve into something useful for users (after fixing the categories and a procedure to get community apps there - does anyone know how or where the apps in the store come from [as it’s not stated in the store app]?). Just my two cents.

1 Like

Fair enough. I have no problems with calling it a store. Software Center like on my Kubuntu machine might be a better description though.

They can call it anything they like so long as it works properly. Just don’t call me late for dinner.


True, the name is not the biggest gripe. But it kinda underscores it. If at any point it would be used to sell anything, the image for it would not be positive or inviting.

There is currently an issue in the upstream GNOME software Gitlab repo for renaming Software. Afaik App Center is their current favorite for a new name.

But it depends on Purism wether they want to follow that. I guess they’ll stay with PureOS Store because they make kind a few changes and also recently added their own Flatpak repo.

Well, the PureOS Store app is now responding after another couple restarts. Didn’t really expect any results after the several restarts done during the day.

I have practically abandoned updating my phone through the store for the above reasons although it randomly tells me about apps it updated on it’s own which I assume is one of the nice functions about it. But yeah even if I get an update done through the store I follow up with a sudo apt update.

With good timing, related post https://puri.sm/posts/introducing-flatpaks-on-pureos/ gives at least some hints to what’s going on. One small thing to check (not much but it’s something):

How to get PureOS Store Flatpaks

If you are on the latest version of PureOS, you should already see Flatpaks in PureOS Store. You can also check via the terminal if the Flatpak remote is installed flatpak remote-ls pureos . If Flatpaks don’t show up, make sure the package pureos-flatpak-defaults is installed via apt-get on your system.

EDIT: note that the “pureos” needs to be --> “PureOS” in the first command

GNOME Software (which PureOS Store is based on) is definitely not fast, and for GNOME Software 44 performance has been an objective:

That said, slowness aside, it works ok on my Librem 5. While I mostly update on the terminal with a dumb script (see below), I can also use PureOS store to upgrade my system - I open it, then do something else, and after that I can upgrade.

Here’s my (very stupid) script:

sudo apt clean
sudo apt autoremove
sudo flatpak update
sudo flatpak uninstall --unused
sudo apt update
sudo apt full-upgrade

Aside from updating I try to ensure to not fill up my disk unneccesarily (lines 2, 3, 5). For a while, I had sudo flatpak repair in there too, but it took too long - I only run it every once in a while now.

PureOS store (gnome-software) hangs sometimes. The spinner just keeps spinning when trying to get updates. This is a known issue and it is reported here.
If that happens, I do:
pkill gnome-software
and start the PureOS store again, and the check for updates then usually works.

Such a solution did come to mind, but I had no idea what the process name of the thing I needed to kill was.

Good to know.

You can add these 2 lines to your script to further clean out flatpak garbage I got this from a Mint forum:

sudo rm -rf /var/lib/flatpak/.removed/
sudo rm -rf /var/tmp/flatpak-cache-*
1 Like