PureOS Terminal will not work

I installed PureOS in a VM to test drive it and the terminal program won’t open. I have reinstalled twice and tried in both VMWare and VIrturalBox, but receive the same result… Bogus!

Yes, this is known issue with gnome-terminal. You need to upgrade vte3 to 0.36.0. If this doesn’t help, try with this workaround:

create file /etc/locale.conf with your locale in it (example: LANG=en_US.UTF-8). Also make sure the same locale is uncommented in /etc/locale.gen. Run sudo locale-gen afterwards (you can use Alt+F2 to open command line prompt).

I cant get the terminal to open either.
@ Mladen Pejakovic
How do i use the command lines you suggested if I cant get the terminal to open?

(you can use Alt+F2 to open command line prompt)

Alternatively, add Debian repo sources and install guake (drop-down terminal).

I got my Librem 15 just today. Had the same problem others noted with PureOS only working in recovery mode, downloaded the latest PureOS 2.1 image, installed that, updated all software to latest, and as far as I can tell everything is working … except gnome-terminal, which is failing the same way as described in this thread.

I don’t see any “vte3” package. “apt-cache search vte” turns up libvte9 (was not installed initially) and libvte-2.91-0. I have both installed now, still no good. I created /etc/locale.conf and ran locale-gen as described above, still no good.

I’d appreciate any help you can provide – at the moment I’m just using xterm, which is functional but not exactly satisfactory.



Hmm, it looks like the problem is that the default LANG value is en_US, which is an alias for en_US.ISO-8859-1, and gnome-terminal wants LANG to be a UTF-8 encoding. If I run “LANG=en_US.UTF8 gnome-terminal” then it works.

And one more update – it looks to me as though the file that controls which locale is used is actually /etc/default/locale, not /etc/locale.conf. Once I set that to en_US.UTF8, all was well.

Brett, thanks for the hint. The exactly same thing I did on my PureOS installation, but I believed locale.conf did the trick.

1 Like

Just got my Librem 15 today. Should’a come with the OS installed as per selections, but shrug.

Installed PureOS 2.1 and immediately ran into the terminal issue. Modifying /etc/default/locale didn’t do anything for me. I reverted that change, and did the following:

  1. Start xterm by pressing Alt+F2 and entering xterm
  2. Switch to root by running sudo su
  3. Open /etc/locale.gen with your favorite editor, such as gedit /etc/locale.gen
  4. Find your locale entry. It's the only uncommented line (without leading #); should be near the bottom of the list.
  5. Replace the format with the desired format. My locale entry is en_US UTF-8, for example.
  6. Save & Close locale.gen
  7. Run the locale generation script with command locale-gen
  8. Try to open a terminal window.

Hopefully this is clear enough for any level of expertise. :slight_smile:

I wasn’t sure where my config was living and was too lazy to look for it. Best to just use the existing gen tool to handle it, in the event that it changes in the future.

I have found another fix:

  1. ALT+F2 and run xterm
  2. Run sudo dpkg-reconfigure locales
  3. Make use ‘en_US.UTF-8 UTF-8’ is selected in the “Locales to be generated:” screen
  4. Select ‘en_US.UTF-8’ as the default locale in the “Default locale for the system environment:” screen
  5. Reboot

Thanks so much Tyler Hoppe. I got my terminal working, yes!!! So that’s taken care of but call me crazy. I don’t see a setting to set up a dual screen wallpaper?? Am I right?

1 Like