PureOS update not installing

So when I run ‘sudo apt upgrade’ at the end of all the other stuff that comes up, I get this…and then run apt list --upgradable

The following packages have been kept back:
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
xxxx@xxxx:~$ apt list --upgradable
Listing… Done
fwupd/byzantium 1.5.7-4pureos0.1 amd64 [upgradable from: 1.5.7-4]
N: There is 1 additional version. Please use the ‘-a’ switch to see it

Not sure I understand why it will not install? Is there something additional I need to do first?

Edit: FYI I cannot get the “contact us” on the Purism site for tech support to work on my L14, no matter what browser I use. It wants to open xdg.open and I click ok, and nothing happens.

1 Like

I get that from time to time (and you and I are not the only ones). I don’t really understand the circumstances that lead to it. However there have been other discussions e.g. "apt upgrade" says "The following packages have been kept back" so a forum search may be in order.

I would always do sudo apt update if I received the ‘kept back’ message, just in order to make sure that I was up to date with the package metadata.

1 Like

Are you talking about the email links on this page: https://puri.sm/contact/ ?

They are all just “mailto:” links - so I guess that means that your browser and/or system are not configured to handle that type of link (which may be an intentional and valid decision on your part). Something has to handle such a link.

For me, from within the Firefox browser, clicking the link brings up a Thunderbird window. (Thunderbird had already been started by me anyway but this was a new window to compose a new email.) So I guess the first question would be … do you have Thunderbird installed?

Anyway, if you have any working email client installed then clicking the link for Technical support should be the same as just composing an email to support@puri.sm

1 Like

I did receive a response from support and advised that I should use

sudo apt total-upgrade

and that worked.

As for the email links I only use protonmail through a browser so that might be why it doesn’t know what to open.


Thanks. I was seeing the problem as well.

1 Like