PureOS Update via software app on L14

Just an FYI, the latest OS update that appears on the software app today will not download, and gives an error message, “The following packages have unmet dependencies”. So then I did run
sudo apt update
sudo apt upgrade
through the terminal with no issues, and it seemed to install updates, but it doesn’t clear the OS update sitting in the software app.

So, as a newbie, not sure if I should ignore what is in the software app for now or what?

1 Like

When I run apt list --upgradable I get this.

pureos-standard/byzantium 0.10.4 amd64 [upgradable from: 0.10.3]

1 Like

Same thing happened to me on my L-14. After doing the sudo apt update, I went back to Software and hit the Reload symbol, and the update went away.

If it doesn’t go away, you could also do a reboot… that sometimes works with Software as well.


Thanks, I’ve reloaded and rebooted several times, still there for now.

I ran into the same problem. I executed:

sudo apt-get clean
and then
sudo apt install pureos-standard

That fixed the issue for me.


Thank you yes that did the trick :+1:


The same thing happened to me. @Amol note helped me clear it to. Thanks! really helpful.