Pureos won't update

For the last few weeks I’ve been unable to install updates. I get something like type dpkg. package into an elevated terminal but when I do that it still doesn’t work. Any ideas? Also when will pureos be able to install on an nvme pcie drive?

If you try this in a terminal:

sudo apt update && sudo apt upgrade

what happens then, is there any error message?

1 Like

I thought it already did?

The Librem 14 doesn’t even have a traditional SATA drive slot, just two M.2 drive slots, albeit that each slot supports either M.2 SATA or M.2 NVMe. However you can easily imagine a customer having either only one drive, M.2 NVMe, or two drives, both M.2 NVMe, and the customer would need some way of installing it / booting it.

1 Like

I get this as its result:

Get:1 http://download.opensuse.org/repositories/home:/FrodeSolheim:/stable/Debian_9.0 InRelease [1,256 B]
Hit:2 https://repo.pureos.net/pureos amber-security InRelease
Err:1 http://download.opensuse.org/repositories/home:/FrodeSolheim:/stable/Debian_9.0 InRelease
The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 054531521A0FC55C
Hit:3 https://repo.puri.sm/pureos amber InRelease
Hit:4 https://repo.pureos.net/pureos amber-updates InRelease
Hit:5 https://mirrors.sonic.net/pureos/repo/pureos amber InRelease
Reading package lists… Done
W: GPG error: http://download.opensuse.org/repositories/home:/FrodeSolheim:/stable/Debian_9.0 InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 054531521A0FC55C
E: The repository ‘http://download.opensuse.org/repositories/home:/FrodeSolheim:/stable/Debian_9.0 InRelease’ is not signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
N: Skipping acquire of configured file ‘main/binary-i386/Packages’ as repository ‘https://repo.pureos.net/pureos amber-security InRelease’ doesn’t support architecture ‘i386’
N: Skipping acquire of configured file ‘main/binary-i386/Packages’ as repository ‘https://repo.puri.sm/pureos amber InRelease’ doesn’t support architecture ‘i386’
N: Skipping acquire of configured file ‘main/binary-i386/Packages’ as repository ‘https://repo.pureos.net/pureos amber-updates InRelease’ doesn’t support architecture ‘i386’
N: Skipping acquire of configured file ‘main/binary-i386/Packages’ as repository ‘https://mirrors.sonic.net/pureos/repo/pureos amber InRelease’ doesn’t support architecture ‘i386’

It still wont update.

Any suggestions?

Seems PureOS doesn’t support 32 bit, and for some reason you have an OpenSUSE repo in your sources…?

I tried to install Steam, Wine etc didnt work and now i get some errors when i update. It didnt affect the system updating though. until this week.

it wont boot on my asrock fatality z77 professional mobo. this was a few months back now. We are still on Pureos 9 so im sure it wont install and boot from an nvme drive. Please correct me if im wrong.

Search in this forum.

There is discussion of people running PureOS off an NVMe drive, as early as April 2018 - and there is also discussion of people having problems.

There has never been an unconditional claim that PureOS will boot on any non-Purism hardware. On non-Purism hardware it is always going to be hit and miss, depending on whether your boot requires blob driver or blob firmware that is not included within PureOS.

The two people quoted above as saying that it works are both using a Librem (13) laptop.

On random other hardware, it might work, it might not work - and if it doesn’t work, it might not be as a result of the NVMe boot drive. If you can be bothered, you would have to fault isolate that.

1 Like

We do have a list of the hardware requirements here: https://tracker.pureos.net/w/pureos/hardware_requirements/

Also, since PureOS does not yet support EFI, you need to set any UEFI the machine might have to BIOS legacy.

This is something we want to address in a future release.

Then there is also the issue of hardware that requires proprietary drivers/firmware. PureOS being a distro that only ships Free Software will not support those out of the box.

As for wine, like stated above, pureOS does not support 32bit, and considering that wine can require a ton of 32bit dependencies (depending on what you want to run in wine), that is the cause of the issue


If I understand those requirements correctly, they mean that 32-bit architecture is not supported, which would explain the “doesn’t support architecture ‘i386’” error messages.


yes correct


And to bring it full circle, Steam requires 32 bit in order to run. Someone in this forum got it to work (I think), but it was an involved process.

1 Like

Ive retried to install it multiple times on my new ssd, its identical to the one running windows so i know its compatible with my motherboard using win 10. I cant stand windows anymore so i need to get pureos bootable from it. Ive no idea where to start though, can anyone help? Would i be better switching to a different distro?

For fault isolation if for no other reason, yes.

Have you enabled “legacy BIOS”? (as noted above by @joao.azevedo)

Yeah its set to CSM enabled, with bios 1.70e I did get an option for storageOpROM but that’s gone in 1.90a. If I disable it (ie full uefi mode) I can’t boot from USB or DVD drive. 1.70e wouldn’t see the windows boot manager for windows 10, so I couldn’t boot it.

I did a fresh install of PureOS 9, updated it, restarted it and now it wont update. I have done nothing else other than update it and now I get ‘Unable to get list of updates’ error. I tried sudo apt update && sudo apt upgrade but nothing changed so I still get the error.

Hello! OK, more questions then:

Are the error messages from sudo apt update && sudo apt upgrade exactly the same as before? If not, please show what the error messages look like now.

What kind of computer is it that you are installing PureOS on?

If you can share the output of the following commands, that might give some clues:

uname -a

cat /etc/os-release

Also, where did you get the .iso file that you used to do your fresh install of PureOS? What is the filename of the .iso file you used? (the filename should include some date and architecture info)

So I ran sudo apt update && sudo apt upgrade and it upgraded 9 items and asked me to restart. I loaded Software updater which also asked to restart. I restarted and it didnt give me an inkling something had been updated. On reboot I ran it again and got this:
Hit:1 https://repo.pureos.net/pureos amber InRelease
Hit:2 https://repo.pureos.net/pureos amber-security InRelease
Hit:3 https://repo.pureos.net/pureos amber-updates InRelease
Reading package lists… Done
Building dependency tree
Reading state information… Done
All packages are up to date.
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following package was automatically installed and is no longer required:
Use ‘sudo apt autoremove’ to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

For the next command I get:
Linux PureOS-Desktop 4.19.0-9-amd64 #1 SMP Debian 4.19.118-2+deb10u1 (2020-06-07) x86_64 GNU/Linux

and finally:




I got the iso from the pureos website, this time though I get a blue dos start up screen instead of the light purple screen I got prior to reinstall.

The pc is a desktop i7 3770k intel with 15gb ram, 120gb ssd for pureos and a couple of nvme and hard drives.

That all looks fine, I think. You did not get any error messages now, it’s just saying everything is up to date.

1 Like

Its still giving me the ‘unable to get update list error’ never had that prior to last update. Maybe its a case of reinstalling it again. Sometimes used to happen with windows xp.