Purism on IBM T420

Hi, I recently purchased the Live OS key from the company and converted my laptop to PureOS. Everything seems to work instead of the WIFI. The Ethernet works, but the WIFI isn’t. I was wondering if anyone had the same issue? or if there is a firmware that I could download for it?

1 Like

Lots of people have that issue.

You would have to know what WiFi card is present.

It’s probably an Intel Centrino but that’s just a guess. Support for Intel WiFi cards under Linux (in general) is reasonable.

This post: Wifi driver for intel centrino n2230 may get you going in the right direction (once you know what WiFi card you have).


Recently I used PureOS on a live USB and I connected to the Ethernet and followed the info on this page to bring the wifi to life:
As irwinewade mentioned, it depends on the wifi adapter of your notebook. But I think quite a lot of notebooks use adapters supported by this driver.
And if you can’t use Internet over the Ethernet, then you can go the way showed in the topic refefenced by irwinewade.

1 Like

Hi Elwar and Hristo,

I tried for 2 hours and looked up everything. I have an IBM T420 thinkpad and the wireless is Broadcom bcm2045b. It’s hard to find the firmware anywhere and reading is vast except for this device.

1 Like

OK, in that case best to find out how it is connected to your system (USB? PCI? something else?) and get the vendor id and product id or drill down to the exact model - and then look up on linux-hardware.org

Looks to me that BCM2045B is Bluetooth though, not WiFi - so please confirm -

which would mean that

is technically true. :wink:

1 Like

I got the same impression as irvinwade.
This broadcom device appears to be just bluetooth (but I am not 100% sure).
I found a nice overview page about this model in German and my impression is that the WiFi options are as mini PCI express and most of them are the Intel Centrinos that would have worked with the solution above.
Have you tested the WiFi under another OS?
Can you confirm that it is available at all? I suppose that you can check on the mini PCI express card which model it is and then look for linux drivers for the model you have.


1 Like

The WLAN card not working because it requiere a Free-Software driver to work in PureOS, so you have 3 options to do:

0 ) Buy a Libre w.l.a.n card.
1 ) Install propietary blob in PureOS.
2 ) Do not using a GNU Operating System.

You can ask to @Quarnero for.

This is the WPAN card v2.1-bluetooth this work in PureOS because it is Free-Software driver.

1 Like

@Oi3B, let me provide two main steps (in general) that are needed (to get any supported non-free WiFi work under Debian 11 or equally under PureOS 10 with few adjustments), only those two steps needed for ThinkPad T420 (I’m quite sure, almost 100%):

Edit (open) your /etc/apt/sources.list like this:

Add to it below line, save and close sources.list file:

Please follow/reuse those two posts of mine (open them into new Tabs):

Not to forget (like myself) what else important:

In accordance to: https://wiki.gentoo.org/wiki/Lenovo_Thinkpad_T420 it is expected, after eventually successful completion of the above two steps (posts within this Forum), that for Centrino Advanced-N 6205 AGN following package will be installed/added to your PureOS installation:

apt list firmware-iwlwifi
Listing... Done
firmware-iwlwifi/stable,now 20210315-3 all [installed]

After above done please execute: sudo reboot and let us know if … if any further help needed.

P.S. If you like please write down your steps and post here those that might help to other people interested on how sudo isenkram-autoinstall-firmware command worked for you.

1 Like