Qubes 4.0.x USB-C Gigabit Ethernet Adaptor Issues

Good day all,

I recently acquired a Librem 15v3, and bought a USB-C Gigabit Ethernet Adaptor to enable me to cable up from time to time. During testing tonight, I realized a couple of things. The device is seen, and is added to sys_usb, as a notification pops up that the following message: “Device Realtek_USB_100_1000_LAN_000001 is available.”

Running a “lsusb” on sys_usb returns the following for the device:

Bus 003 Device 005: ID Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter

When I try to use the qubes devices menu to assign it to sys_net, I get a long delay(30 seconds+) before I get the notification telling me that it is attempting to attach the device to sys_net.

During the delay, I can go to sys_net, and use lsusb to see that the device is seen, but after the notification pops up, lsusb returns nothing for the device.

Before notification:

[sys-net ~]$ lsusb
Bus 003 Device 012: ID Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter
Bus 003 Device 001: ID Linux Foundation 3.0 root hub
Bus 002 Device 001: ID Linux Foundation 2.0 root hub
Bus 001 Device 002: ID Adomax Technology Co., Ltd
Bus 001 Device 001: ID Linux Foundation 2.0 root hub

After notification:

[sys-net ~]$ lsusb
Bus 003 Device 001: ID Linux Foundation 3.0 root hub
Bus 002 Device 001: ID Linux Foundation 2.0 root hub
Bus 001 Device 002: ID Adomax Technology Co., Ltd
Bus 001 Device 001: ID Linux Foundation 2.0 root hub

The device lights up just fine when a network cable is plugged into it, and blinks normally.
Has anyone else had any such fun getting USB-C Gigabit Ethernet devices to work?

1 Like

This is a a Qubes question rather than a Purism one. In order to use LAN over USB in Qubes 4.0 you need to have the whole USB controller (not only the single device) and the network controller active in the same VM. In effect that means having a combined sys-net and sys-usb Qube. There is an option to configure this during install, otherwise you will have to change it manually now.

Since Librems only have one USB controller for all ports that means you will not be able to connect USB devices without potentially exposing them to your internet connection. Practically the attack surface in sys-net will be very small though since nothing else should really be running there anyway.

Thanks for this reply. Looks like I need to re-evaluate my threat-model, and possibly create a separate sys-usb-net NetVM for when I want to use the USB Gigabit adapter.

Have you got this to work?

I have not been able to get this solution to work on a Librem 13, trying to use the USB and/or USB3.

What is the configuration that actually works, getting the USB Ethernet to work with Qubes?

(I’m getting the error, “Unable to reset pci device”, no matter the sys-usb configuration I’ve tried. For some reason i just can’t attach a USB or USB 3 controller to any VM. If you got it to work, please let me know the configuration used.)

I had to follow avog’s advice and make my sys-net my sys-usb qube at install. So in essence, my sys-net is also my sys-usb qube. That was the only way I could get a USB3 Ethernet adapter to give me network access. You should be able to create ta combined sys-net (with sys-usb capabilities) after install as well.

1 Like

This is what I’m following, post install. Still does not work. At this point I’m about to re-install, just to get this solved.

Before I do I just need to know, this works. You have a Librem. You’re able to connect to Ethernet through the USB port (USB3??)… and you’re still able to use the USB port for optical mouse & keyboards etc.?

1 Like

Were you using Purism hardware?

My install doesn’t allow me to select the sys-usb creation & combine sys-net & sys-usb into the same device?

The option below is disabled on the Purism Librem 13 install:

If anyone else had this problem, the solution was to be sure all USBs were disconnected during the reboot of QubesOS after the initial install. After doing that the greyed out option was now available.

The ethernet problem was solved on the Qubes OS root install doing this.

It still has not been solved in the Qubes VMs. So far, I can’t get a network to pass through to a stand alone VM.

The domain VMs based on the Fedora template the network passes through .

1 Like

@Emily I’m still not able to gain access to my router’s lan through the Ethernet adapter connected to the sys-usb VM attached to the sys-net VM. Were you able to solve this problem?

The Ethernet adapter works fine when I re-install and choose to combine the sys-net and sys-usb VMs.

Yes, I was able to get that working. I had to re-install Qubes. On the re-start, be sure ALL usb devices are unplugged, before it reboots. Then be sure to select the option to combine sys-usb & sys-net to share internet.

The problem I had though was lightbox erros, and PCI attachment errors. Others seem to be able to run Qubes just fine on Librem. I had to give up on it for now. But will give it another go on the next Qubes release.

If you’re able to make it work, let me know.

I have no problem with the ethernet adapter when I combine sys-usb and sys-net at install.

What I would like to do, but not able to do, is separate the sys-usb and sys-net at install and still be able to use the ethernet adapter. Up to this point, I have not figured out what I must do to make the adapter work while attached to sys-net through the sys-usb vm.

I was not able to get Ethernet to work, without combining them. I tried separating out the USB3, but just couldn’t get it to work.