Qubes on Librem Mini

I received my Librem Mini a few days ago and have been trying to get Qubes installed. You may run into issues starting the graphical installer that can be solved by adding inst.text in the boot options.

The text installer for Qubes is not fully functional but works well if you have another computer to connect over VNC.

Now I have the OS completely installed, but I can not get to the login screen because my X server is not working correctly.

When booting, I get an error that “failed to start load kernel modules.” Once it gets to where I would typically log in, there is a typical X error page with two different errors before printing “no screens found.” First, it prints “modprobe: FATAL: Module fbcon not found in directory /lib/modubes/4.19.94” Then, it prints “intel: waited 2020 ms for i915.ko driver to load.”

Any help would be much appreciated, using PureOS for the time being.

1 Like

Are you using the latest stable release of Qubes? Given this is newer hardware you would probably benefit from the newest kernel you can get for dom0. I know that until very recently we shipped an older Qubes 4.0 build for customers who requested Qubes so you may want to try downloading the latest 4.0.3 iso from https://www.qubes-os.org/downloads/.

Yes that is what I have been using.

Hmm OK. I’m trying to find a way for you to either get a “testing” version of their install that’s a pre-release of 4.0.4, or otherwise a way to get their most recent kernel. (I thought they had a 4.0.4 pre-release image on their downloads page but it turns out they don’t).

The main issue with Qubes compatibility always comes down to the fact that dom0’s Fedora release lags behind so if you have newer hardware often the older kernel can have trouble supporting it.

1 Like

I know it’s not completely analogous, but I have yet to get Qubes on my own (non Librem) system. One thing I tried with a degree of optimism, that may be worth trying for you, was installing Qubes on another similar system then updating dom0 kernel to -latest (as well as applying all the dom0 patches). For me this did not work, but if you have a system around to try with it may be worth seeing how that goes.

You can also try using Qubes Builder to build with a newer kernel and/or building a 4.1 iso for testing. I’ve even pulled iso’s from the Qubes openqa server which may or may not help.

Here are the steps to try the latest Qubes kernel, which hopefully you can do if you can boot far enough to get to a console:


I actually can’t get to a console. I have tried switching to a different TTY but my screen will start flashing and the machine is unusable.

I guess I will keep using PureOS until the next Qubes release.

I had no issues installing Qubes 4.0.3 from either the shipped version of coreboot or PureBoot on the Mini with the default installer target. Which are you using, and what exactly is the issue you’re seeing?


Well that’s good to hear, maybe there is hope. I’m not doing anything fancy though, just creating a bootable USB of Qubes 4.0.3 with dd. I can’t get the graphical installer to work and even after getting it on there with the text installer I can’t login. I have tried multiple USB devices with the same results. Any idea what I might be doing wrong?

Sorry if this is obvious to you, but are you running the sync command after dd and before unplugging the USB to ensure all the data is written before unplugging?

1 Like

Or use the conv=fsync option on the dd command.

but which firmware are you using?

I ordered my mini without any storage or memory so it came with seabios. I have since added an m.2 ssd, 2.5" ssd, and two sticks of memory.

ok, I’ll flash the release coreboot firmware on there and see if I can reproduce. Using Qubes 4.0.3 ISO dd’d to USB?

1 Like

I’m in the same boat. SeaBios -1.13.0.-1-g55d6754 and Qubes 4.0.3 ISO dd’d to USB on a new Librem Mini.

meaning what exactly?

Meaning, I am unable to get to the graphical installer using Qubes 4.0.3 on a USB with the SeaBios -1.13.0.-1-g55d6754 per the original post.

so in trying to reproduce this here, I’ve come up with 3 different potential outcomes:

  • Qubes installer boots as expected
  • Qubes installer boots to a black screen, monitor has signal
  • Qubes installer boots to a black screen, monitor reports signal lost

There doesn’t seem to be any exact correlation to determine the outcome, but I’ve found that the best chance for success is not using a hub, and using only the USB2 ports for the installer stick and keyboard etc.

ok, anyone having this issue, please use the script here to download/flash a coreboot test version which should fix the issue:


download, run as usual (sudo bash coreboot_util.sh), flash precompiled update.

this build contains an updated/reconfigured VBIOS blob, as well as enables the boot splash image on the Mini (switching video modes is slow, I know).

please test / LMK if any issues, both with HDMI and DisplayPort outputs


1 Like

could this issue apply to booting PureOS on LMini as well ?
i’m having a little snag with mine and hopefully i’ll be able to resolve it with @joao.azevedo