Recently can't send MMS anymore

Everything was working fine, but just a few days ago I noticed I can’t send MMS anymore. The little check doesn’t turn green and my wife’s phone doesn’t make noise (She’s in the group :slight_smile: ). I can receive them just fine. I get pictures and all that. I can send regular SMS, just no luck replying to group messages.

I was digging through the journalctl messages and I’m seeing what appears to be HTTP 200 responses from the mms endpoint and it ends up saying message sent, but when I review the .status file in the .mms/modemmanager folder the individual number delivery_status = none.

I also tried a different group just to make sure it wasn’t something clogged up with that particular conversation.

Thanks in advance for any ideas you might have!


I am having the same issue. I can received MMS but can’t send them. Nothing changed I am aware of. I use T-Mobile.
Settings I use in chatty are:
I just got off the phone with a T-Mobile rep who said there are not blocks on the number in question, it should be working.
In chatty I get a check mark which makes me think they are being sent, but they are not.

1 Like

Interesting. My MVNO uses t-mobile, but different MMSC. I get the grey check mark, it just never turns green.

1 Like

From the t-mobile website:

“This document will walk you through setting up internet and pictures messaging (MMS) on a non-T-Mobile phone, but there are a few things to keep in mind before you get started:
We can’t guarantee these settings will make an unsupported device fully functional on the T-Mobile network.”

No guarantees, I guess.

1 Like

I am on T-Mobile also, in the US.
With your MMSC and APN settings, I do not receive MMS, only SMS. And MMS that I send are not received.

With the following settings:
APN: pwg
I can receive MMS. MMS I send are still not received.

1 Like

Can anyone confirm that the new AweSIM or SIMple plans send and receive MMS?

The weird thing is a couple of days ago I stopped receiving SMS and MMS messages, and I am also on T-Mobile. I am able to send SMS just fine but I cannot send MMS.

There have been no recent updates to Chatty, and it seems like so far only T-Mobile users are experiencing the issue. Maybe something has changed on the network side?

Hi All,
Looks like it was something T-Mobile changed on their side and luckily the developer of mmsd-tng already has a fix in place!

I stayed on the 1.x version because of what package was already installed on my Librem 5, but after upgrading to 1.13.0 I can send MMS again!


That’s great to hear! I downloaded the artifacts for debian=build but I am pretty terrible at compiling stuff :sweat_smile:. Would you mind posting the steps you did to compile it?

I can try to explain the steps, but warning my way doesn’t make a deb package and install it officially because my plan is that once this new version makes its way through the proper reviews and repos I can just upgrade the installed package and go back to normal.

However since I really wanted to get this working sooner than later here is what I did:

  1. Download zip of the tagged version from repo (sounds like you did this already)
  2. Extract this archive out into a working directory
  3. Review the README file because this usually shows up in the git repo UI and normally has the instructions.

(The README is where I got the next two commands)

  1. run: meson _build
    (This will review your setup and make sure you have all the necessary compilers and libraries installed)
    This is also where you will hit your first friction because I didn’t have two of the needed libraries. In my case I didn’t have:

a. cares (Install by running: sudo apt-get install libc-ares-dev
b. libphonenumber (install by running: sudo apt-get install libphonenumber-dev

If you see other messages about other missing libraries get comfortable with running: apt search (libraryname) and then you can review the options available in your repos. Hint: You’ll probably have the library installed, but need the package that has the code for compiling and they usually end in the -dev

Once the meson command finishes successfully you are ready to actually compile it:

  1. run: meson compile -C _build

If it compiles successfully you can continue:

  1. Turn off existing mmsd-tng service by running: systemctl --user stop mmsd-tng

  2. Try your new version by running: ./_build/mmsdtng -d

Now you should be able to see the log of that service and you can try to send an MMS and see what happens.

Hope that helps a little and I guess will at least give you some different steps to research further. Let me know if you have more questions and if that works successfully then I can show you how I told the systemd service to use my built version instead of the existing one.

Good luck!


Seems to work for me. One point of confusion…
I did the build instructions here:

It installed the new mmsdtng into the /usr/local/bin/ directory but when I rebooted it uses an old one located in the /usr/bin/ directory. So…
I did:
cd /usr/bin/
mv mmsdtng mmsdtng_old
ln -s /usr/local/bin/mmsdtng mmsdtng
Now it works even after a reboot.
1 Like

Do you have any idea if this fix would be a Chatty update or a Byzantium update? I don’t want to build the fix from source as I lack the time and I’m not confident about not messing things up in trying this fix myself.

I am unsure if I want to go through the whole compiling either. It looks like it is a systemd service that needs to be updated so it will be some type of Byzantium system update.

1 Like

Hi All,

If I understand it correctly it will appear as just an update to the mmsd-tng package.

Right now an apt info mmsd-tng is showing it as:

Package: mmsd-tng
Version: 1.12.1-1pureos2
Priority: optional
Section: comm
Maintainer: PureOS Maintainers <>

Once it is 1.13 you’ll be good, but I have no idea how long that will take and I was in a bad spot without MMS working so I had to compile. It really didn’t take long to figure it out and compile and you can just tweak the systemd config file for it: /usr/lib/systemd/user/mmsd-tng.service and redirect to to use your compiled version until the new package comes out.

In no way am I saying that tasks like this should have to be done by an end user, but being able to roll with stuff like this as quickly as we are (especially thanks to Chris who jumped in and debugged and fixed the issue so fast!) is what makes these libraries and a device like this so special to me

I didn’t realize there were user level systemd services? I saw mmsd-tng in the full journalctl output, but couldn’t find it when I tried to narrow it down with just a -u mmsd-tng, but adding a --user fixed that.

yes, this was the issue and we will need to backport this version.


mmsd-tng runs as a user service, because it is parsing files (the MMS’es) it receives from unknown sources, and that has some security implications. So you do not want that to run as root


Yes, we will be updating this package.


Can this be sped up in any way? I see the package is sitting at 3 days remaining, why does it need 5 days to sit in landing?

to test for bugs or regressions before releasing to a wider group of users.


I am having similar issues even after the recent update of mmsdtng to 1.13.0 and chatty 0.7.0.rc5 (and reboot).

The issues I continue to experience using T-Mobile and carrier’s recommended settings:

-unable to receive SMS
-unable to reliably receive MMS. I have received random spurts of MMS group text and images.

-I am still able to send SMS, but not MMS

Any troubleshooting advice for this issue?

1 Like