Recently can't send MMS anymore

Your situation and my situation sound similar. My questions are: is it the carrier (T-Mobile) or the software, and does AweSIM eliminate these issues?

just wanted to add to this.
I’m on SIMple plan and no luck with MMS at all

1 Like

@librem5 @Sarcasmo220 could you open a terminal on the phone and run the following command:

sudo mmcli -m any --messaging-list-sms

and post the output here.

1 Like
purism@pureos:~$ sudo mmcli -m any --messaging-list-sms
[sudo] password for purism:
    /org/freedesktop/ModemManager1/SMS/1 (received)
1 Like

ok, so you do not have any issues with messages stuck in the modem.

can you tell me what is the MMS setting you have in the chats application, in: chats > preferences > SMS and MMS settings, it is at the end of the page.

1 Like

Name: pwg

1 Like

oh this is after recent reboot, let me try sending MMS and then run it.

1 Like

I’m still unable to send group SMS or send or receive group MMS or send MMS to a single person. I’m on T-Mobile. I emailed Purism support a few days ago and I was told that MMS is proven to work with SIMple, so I was planning to switch….🫤

For t-mobile can you try these settings;


In in: chats > preferences > SMS and MMS settings, then press apply at the upper left corner.

And let me know if this worked.

1 Like

Just rebooted phone sent MMS to/from phone and I see
purism@pureos:~$ sudo mmcli -m any --messaging-list-sms
No sms messages were found

1 Like

ok, this means that there is no pending inbound message in the modem. Did the other phone received the MMS?

1 Like

nope, other phone didn’t receive MMS.
How do I check if mms is even enabled? (which service should be running?)

1 Like

Settings in Chatty prefs and Mobile prefs are what you gave. I am sending .jpg files to iPhones but these are not being received.

The other subscriber is also on T-Mobile. I can receive images that the single person sends to me. They can’t see pictures I’m trying to send to them.

MMS is completely fine with SIMple.
I had to re-flash the phone and now everything is good.


I reflashed my L5, with updated chatty version 0.7.0rc5, mmsdtng version 1.13.0, system: Linux pureos 6.1.0-1-librem5 and sending and receiving SMS/MMS began working with T-Mobile.

However, about a week ago, my ability to send SMS abruptly stopped, although I could still receive SMS.

When I took the SIM card out of the L5 and reinserted it back into the iPhone, interestingly the SMS generated on the L5 was then subsequently received by the other party.


For me there are messages stuck in my modem:
/org/freedesktop/ModemManager1/SMS/139 (receiving) /org/freedesktop/ModemManager1/SMS/138 (receiving)

I have chatty 0.7 and mms-tng daemon 1.13 installed, using Awesim T-Mobile backbone. Issue same as previously reported no out or incoming MMS.

Tried to build 1.14 to see if there is an improvement but getting lots of compile errors pickle.load object etc

I should also mention that on the client side my side chatty spams the conversation with mms messages that failed to send every time i think you open up chatty. That has been an issue though for ~ 1 year so probably known.

Message: You received an MMS, but it expired on: 1970-01-01 08∶59

Message: You received an MMS, but it expired on: 1970-01-01 08∶59

If you receive the contents of the MMS, it will be displayed above. Is there any problem?

check your system date, if it is correct.