Recovering the Touchscreen feature on Surface Pro

Hello Dear Community!!!

I tried changing my operating system from Windows 10 to Pure OS, but the Purism community Guided me that it would be easier and more functional if I simply changed to Ubuntu due to proprietary software, compatibility issues, etc.

And so I did, thanks to the help from users from this awesome community!!! Now I come back to this space to ask for help in recovering the touchscreen feature on my Surface Pro (it went away after I switched to Ubuntu). I know this is not specifically about Purism, but this community is very helpful (so here I seek Guidance again)!

I did
xinput --list and here is what shows up:

Then, I entered the option I think refers to my Surface Pro name/ Touchscreen name. But I get this warning and nothing happens:

Also, I tried it a different way through calibrating through the Startup Application Preferences but nothing worked either: I don’t actually know if I was doing it correctly, I simply followed a tutorial I found.

I installed Arch with KDE Plasma on a Surface Pro 3 once upon a time and managed to get all the hardware working after some effort.
The touchscreen was a little tricky, but really it was the WIFI that was the biggest pain.

I would assume the kernel in Ubuntu is new enough to support the touchscreen, but maybe not.

My setup was running X11. You clearly have Wayland based on the WARNING I am seeing in your second screenshot. What I did was for X11 so it won’t help you, but I’ll see if I can’t find anything that might help you.

Edit: I’ve seen a few posts online that seemed to indicate the touchscreen worked in some older Ubuntu versions. Either way though, I think you may be interested in

You might browse some of these “Linux on Surface” topics on Reddit and see if anybody has posted about the issue:

This might be helpful, too, especially the post-installation info:

(BTW, your second screenshot has to do with the keyboard, not the touch input. I’m not sure why your touchscreen isn’t listed.)