Recovery shell for Librem 5


I recently tried to add a microsd card to my Librem 5 as the /home partition and botched the entry in fstab and now the phone won’t boot at all. I believe I just need to correct (or remove) the entry, but when the phone boots, I see a few errors relating to the failure to mount the device, like:

[ TIME ] Time out waiting for device SOME-UUID.
[DEPEND] Dependency failed for SOME-UUID.
[DEPEND] Dependency failed for /home.
[DEPEND] Dependency failed for Local File Systems.

It does continue on and stops after:

[  OK  ] Reached target Host and Network Name Lookups.

At this point, it is completely unresponsive to any keyboard/mouse/touchscreen action other than the power button or pressing ctrl, alt, delete, which reboots the phone. As I mentioned before, I believe all I need to do is correct the fstab, but I don’t know how to access it. I tried the first suggestion in the video here, but the device never shows up in /dev and I’m not up for the second suggestion involving soldering since I’d rather flash the phone and start from scratch.

In short, is there anyway to access the phone’s filesystem so I can make the correction or do I need to start over?

There is something called Jumpdrive that could be useful for this, maybe. I never tried it myself but it was discussed for example in this thread: Librem5 (Evergreen) serial console
where it seems like someone succeeded in doing something similar to what you need.


Jumpdrive is exactly the tool to use here. It exports eMMC as a USB mass storage, so you can mount it and make any changes you wish. It also runs a telnet server over USB network, so you can use its shell to apply changes too.


Ahhhh! Thanks so much to both of you! This let me do exactly what I wanted. Had a small hiccup, which I assume was the orientation of the USB-C connection, but following the steps allowed me to connect just fine. I was able to edit fstab as desired and things are back to normal. Thanks again!!

1 Like