Redirected to user login screen after login

I have a Librem 15 v3 that I ran software update recently. Now when I try to log into my user account, I am taken back to the user account login screen. I’m not sure how to troubleshoot this issue. Any advice would be appreciated. Thanks.


Try logging in with X session:

I’m not seeing the gear button. Also the trackpad stopped working.

Hm, strange. Can you please try the following:

  1. Press CTRL+ALT+F2 to enter another virtual terminal, you will get a black screen very similar to this:

  2. Type in your username, hit ENTER, type in your password (no feedback characters will be shown), press ENTER again:

  3. You are now logged-in. Type the following command and press ENTER:

sudo dpkg --configure -a:

  1. You could also try to update your system (this will work if you are connected to internet):

sudo apt update && sudo apt full-upgrade

1 Like

I was experiencing the same exact issue ( PureOS User Login Fails ).
I really feel it was an issue with the upgrade you guys pushed, please verify and perhaps post a disclamer and a fix as soon as possible.
The process @mladen layed out indeed worked and now my librem works flawlessly. Thank you!

I have just installed the latest updates, and after rebooting my machine my user avatar doesn’t show and once I enter my password all that does is it refreshes the login page and requests to input my password again.
I cannot bypass the user login page, please help!

This issue was addressed and solved in another thread: Redirected to user login screen after login

To all of you with the issue: how did you performed the upgrade, via Gnome Software Center or directly using apt commands?

We would also appreciate if you could provide us your /var/log/apt/term.log and /var/log/dpkg.log files (you can mail to @support). Thanks for all your help and patience!

Also, dealing with a broken upgrade is described here:

Running the dpkg command fixed my issue. I used the Software update application to update, and I’ve emailed my logs.


I updated about 30 software items via the Software Center
including the OS.

I then had the exact same issue, always coming back to the login page with an empty box and my username next to it.
I then did what Mladen suggested:
I pressed CTRL+ALT+F2
A blank black screen appeared, but without the login prompt.
I was able to type (like in a word processor), but nothing else.

I powered my Librem 13v2 off and started it again.
This time pressing CTRL+ALT+F2 brought up a black screen WITH login prompt.
After typing in my user name and password it said: incorrect login.
I tried again and again, making sure I was using the correct user name and password.
No luck.

I then used the user root and the corresponding password.
Login was successfull.

Next I put in
sudo dpkg --configure -a
But I got an error message (something like could not find a)

I then put in
sudo apt update && sudo apt full-upgrade
and then followed along
The update process worked fine.

I restarted my Librem 13v2 and everything was fine.
The login page showed up, with my user name and a symbol in the box.
I typed in the password and it worked fine.

It started with some kind of setup wizard
and now everything is back to normal again.

I just had this problem after a Gnome Software Center update. It also wouldn’t accept my userid as on the list of sudoers, so I had to use root before dpkg

I have a simular issue.
After upgrading I can log in, but after this the screen is only blue.
If I press the key “super” the slider on the left side shows up, but without icons.
I can “start” a programm but after this I end up with the login screen.

I followed your advise

  • Press CTRL+ALT+F2 to enter another virtual terminal, you will get a black screen very similar to this: -

the screen that showed up was not 100% the same.

PureOS GNU/Linux librem tty2
librem login:

I entered my user name (root)
and the password also.

I tried several times
and received always the message “Login incorrect”

Tell me what to do now.

Other than reinstalling, you cannot do anything. But try entering your password first (instead of your username) to be absolutely positive you are typing the right password.

Now I have a problem with the reinstalling.

After choosing 1 (the harddisk)
and after starting the installer
I can do the first steps
the installer does not offer to choose the storage device.
I cannot go on.

??and now?

ok this problem I solved

And here is the next:

After reinstall I have not the same the start screen it is different.

Before I did the reinstalling I checked the harddisk with the disk utility on my Mac.
The hard disk had 3 partitions (original before I started the reinstall process)

The install process is asking to make 4 partitions. Why is it different?

Next question: How bout the encryption? Which partition?
I tried different ways, the result was always different / not working / not the same like it was before the crash.

I managed to make one screenshot
have a look:

[ 1.317620] i915 0000:00:02.0: firmware: failed to load i915/sk1_dmc_ver1_26.
bin (2)
/dev/sda3: recovering journal
/dev/sda3: clean, 212214/1310720 files, 1172823/5242880 blocks
[ 4.273403] usb 1-3: firmware: failed to load ar3k/AthrBT_0x11020100.dfu (-2)
[ 4.273600] Bluetooth: Loading patch file failed

Having similar issue as the Mar 31 post on PureOS User Login Fails.

It’s a new machine, experienced the login loop the first time it was rebooted after initial setup. Performed the full update per the Mar 31 recommendation. No apparent effect.

Went through the full update again (0 updated since it was just done). Still no effect.

Tried to login using other options: GNOME, GNOME on Xorg, and System X11 Default, and GNOME classic. They all just hangup with a grey screen and mouse pointer. Can startup Kodi but that is not my interest at the moment.

How to fix the login loop problem?

Can you try: ?

Also, a log would be very helpful here to help us determine what is going on.

Users suggested that system update will solve the problem:

I’ve got the same issues as other posters. My problem is that when I try Mladens solution it asks for a password for a user name I have no password for. I haven’t used that user in months. I can’t even remember ever using it at all. It is the computers name.

My normal user name appears after I decrypt the drive but I get “that didn’t work”.

I think you misread that.
The computer name is the prompt.
Just enter your actual user name.
Then you’ll be asked for a password.