Reflashing Byzantium failing

I’m not having an easy time reflashing my phone to Byzantium. I’ve tried from my Debian Buster machine and also from a PureOS 10.3 Live USB stick. The phone is the Evergreen version.

The script never finishes and the phone just sits there with an orange light. The last thing the script prints is:

3:2      3/ 3 [=================100%=================] SDPV: jump

If I run the script with the --debug option the last few lines printed are:

Wait for Known USB Device Appear...
>Start Cmd:CFG: SDP: -chip MX8MQ -compatible MX8MQ -vid 0x316d -pid 0x4c05
>Okay (0s)
New USB Device Attached at 3:2
3:2>Start Cmd:SDP: boot -f u-boot-librem5.imx
6400%3:2>Okay (0.809s)
New USB Device Attached at 3:2
3:2>Start Cmd:SDPV: delay 1000
3:2>Okay (1s)
3:2>Start Cmd:SDPV: write -f u-boot-librem5.imx -skipspl
99%3:2>Okay (0.758s)
3:2>Start Cmd:SDPV: jump
6400%3:2>Okay (0.154s)

After restarting the phone after 5 minutes of waiting the phone boots back to the old installation of PureOS.

I’ve been following these instructions:

Thanks in advance for any help you can offer!

I think that USB things can sometimes behave strangely and they can sometimes work partly so you don’t realize that there is a problem. A USB port (or cable) may seem to be working but there may still be problems with it, depending on what you are going to use it for. Therefore, I suggest:

  • try the same thing but using a different USB cable
  • try the same thing but turning the USB cable around in different ways (2x2x2=8 possible ways :upside_down_face: for a USB-C cable, all should work the same in theory but it may happen that only one orientation works)
  • try the same thing but using a different USB port on the computer, if it has several ports
  • try the same thing but using a different computer
1 Like

It may be also worth trying a USB 2.0 port in case you’re using a 3.0 one.


That was it. I was using a USB-C to USB-C cable on my laptop. I used USB-A to USB-C cable and it worked right away. Thanks!

1 Like