Right click on Librem 5

Even after months of use of Librem 5 I still have no idea how to do “Right click” on a Librem 5 using the touch screen.

  • if I short click a file, the file opens
  • if I double click on a file, the file opens
  • if I long press on file, the right click menu appears, but then it disappears when I lift my finger, so it is de facto unusable

What I would expect would be something like that:
Upon long press, the right click menu appears and stays visible after lifting the finger. Then the user can click on an item in the right click menu or click outside of the right click menu to close the menu. If the clicked item in the right click menu has sub menu, then the sub menu opens and remains open after lifting the finger.

I also don’t understand why both short click and double click do the same. I would have preferred that a short click just selects the file without opening it like on a notebook. This would prevent opening files on accident and would allow for selecting more files.


This has also been my experience. In general, while connecting an external keyboard and pointing device works as one would expect with any desktop, there are actions that only become accessible with a ‘right click’ analog that don’t seem to be invokable with touch.

Sure, I could connect a mouse or a keyboard. But this is not the goal.
At some point if I need to carry around a keyboard, a power bank, and a docking station, then I wonder why I don’t just use a notebook. :smiley:
Right click could be achieved by a software change.
The energy consumption could be improved by software changes.
And for getting rid of docking stations, we would need a second USB-C (and/or a HDMI port) in the future Librem 5 iterations.


This works for me on Pinephone Mobian Phosh:

  1. Press and hold, the context menu pops up.
  2. Don’t let go!
  3. While holding the press that brought up the context menu, use a finger on your other hand to tap the desired selection.

It’s easier to do than it sounds. Of course, it would be nice if the context menu just remained after you lift your finger… and I could swear that it worked that way in early versions of Phosh.


I would be curious to know the reasoning behind the design decisions from Purism side.
Single click and double click leading to the same result sounds like a waste.
Right click possible only with two hands sounds like a terrible UX.
And I am curious if I am the only person who thinks that this should be improved.

1 Like

Since you are talking about opening files, I assume you experience these issues in Files.
I solved the issue of “Single click and double click leading to the same result” by going in “Preference”, then “General” section, change “Single Click” to “Double Click” for “Action to Open Items”.

Then you can achieve the behavior you describe:

  • Single click selects the file
  • Double click opens the file

To open the menu, I use the Menu key from the terminal keyboard layout (I don’t remember where I have found this solution on the forum).

In phosh, long press already open then menu (which stays).


Thank you, this works!

This is not a great UX, but it works too.

For me when I long press a file, this shows the menu, but the menu disappears the moment I lift my finger. And clicking at the same time with the other hand did not worked for me. So currently the Menu key from the Terminal keyboard seems to be the main option when you don’t have a mouse or an external keyboard around.


My guess would be that they did not spend a lot of time working on the file explorer yet. See the priorities here: https://puri.sm/fund-your-app/.

I have almost the same problem, but with a workaround that does not need an external keyboard. My Librem 5 arrived 4 days ago. I believe it has the Evergreen hardware, although nothing indicates that in writing. It runs the kernel.

In Files, a file can be selected with a light (usually) tap on the file name. The file does not open. Longer tap brings up the right-click menu, which disappears before any option can be activated. Photon’s two-hand technique does not work on my device. Nothing changes after switching the Preferences>General>Action-to-Open-Items.

As others have noted, the simplest way to open a file is to bring up the virtual keyboard and tap Return while the file in question is highlighted.

For the other right-click options, there is a menu button in the top-right corner of the Files page. Tapping the menu button while a file is highlighted, you find a number of icons that activate Cut, Copy, Paste, New Folder and one or two others that I have not been able to decipher.

There are no words indicating what the icons represent. However, if you have access to a computer with Nemo or PCManFM-Qt file manager (e.g. Linux Mint or Lubuntu), the right-click menu on one of those will display almost identical icons along with the corresponding words Cut, Copy etc.

1 Like

I have to qualify my earlier comment. The problems arose when the files were arranged in List View (which seems to be the default, since the Files application first opens with that setting in a brand new phone). Using the Icon View instead, files open easily with one or two taps, depending on the setting chosen in “Action to Open Items”.

The “View” switch can be found at the bottom-right of the Files page (not the rightmost element there but the one next beside it).

With the “Action to Open” set to two taps (and View set to Icons), the file can be selected with one tap, and then the menu button in the top-right corner enables the various other right-click possibilities.

The “View” setting turns out to be crucial for effective operation of the file manager.

This has nothing to do with “design decisions”. Context menu behavior is a GTK bug: https://gitlab.gnome.org/GNOME/gtk/-/issues/5115


Where did you find the “Preference” folder?


(Sorry, French :sweat_smile:)


Thanks a lot for the tip about the Menu key from the terminal keyboard :slight_smile: