Root Access on Librem 5

When I first got my Librem 5, I was able to get root access using either su or sudo su (can’t remember which now). I didn’t make any account changes nor any password changes. But I no longer have root access. Both ways give me authentication errors. One says my account has expired and says to contact my system administrator. So whatever happened, I can’t see how I could have caused it. So how do I get root access back? My Librem 5 is starting to feel more like an Android device when it denies me access.

I’m pretty sure the root account is disabled on PureOS.
Can you do sudo some-other-command successfully?

To enable the root account, sudo passwd root I think will let you set a password on it, after which you can sudo su.
(Someone correct me if wrong, it’s been a while).

I use sudo bash for a root term
You can also use sudo cmd

It’s sudo -s.


Thanks for the replies here. Problem solved.

Which method did you use?

It is - and that’s the way it should be left. It just isn’t needed (in the Debian family).

You never did have a usable root account. It is disabled out-of-the-box. It is unlikely that anything has changed.

sudo -i

1 Like

“sudo -s bash”

Sudo bash (enter 123456)
whoami root

cd root, ls (yep, it worked). I should be locked out of here. But I see the protected files and directories in the root directory.

1 Like