Root password forgot?

my phone is encrypted etc, have no problem getting in, i cannot sign in a terminal with su.

i only use certain words with certain numbers, so… have tried all twice in the combinations possible. is there away to change or see what password i used last. the L5 USA full upgrade to current… no problems other than getting root. Also cannot find link to pureos arm version to put on a stick, anyone have a link? I have some instructions on how to unlock using the system from the stick but need iso.
thanks … dave

Usually the root account is disabled by default nowadays. If you want to reset the root password, you can follow the instructions here: Since i have no access to my root account on my newly installed pureos 8.0 - #2 by mladen

I strongly suggest contacting Purism support with an email to to get the best help here as messing with the root account can become a security risk as it is an easy target.

1 Like

I wouldn’t mess with root either…just sudo instead.

1 Like

Hey, just tried everything does not work… sudo su response is enter password.
su response is enter password

So… can’t install anything or update and the rest.

Was that last full-upgrade a problem , did it change something… anyone else have same problem?

Where is the link to full arm version of the OS to install onto a memory stick?

Did you try 123456 or whatever is the unlock code of the phone?

Not yet I will try it right now

No, doesn’t work.

sudo su will not work. Login to the root account is disabled on PureOS.
sudo <your_command> however should still be possible.

1 Like

If I use sudo apt full-upgrade the terminal asks for password

Yes, but it’s “your” password that it is asking for, not root’s password.

By “your” password, I mean the password for the purism account, which is also the lock screen unlock password. If you can type a sudo command at the terminal then I assume that you are able to get into the phone as far as doing that, so you must know the lock screen unlock password.

For the record, I would test the sudo command with something harmless like sudo date

As others have said, the root account is by default disabled on the Librem 5 (on all Debian-family distros?). You have no need to enable the root account. You have no need ever to use the root account.


solved problem, sudo works now.

1 Like