Root terminal access


#1

Using my password account (same as the one used with sudo install to install any packages, to run the Root terminal, it is not working. I get a 'incorrect password. why ?


#2

My Root password is not the same as my user password I use when I sudo a command. The installer asked for both accounts when setting up PureOS, Root name and password, and the username and password.


#3

During the installation it was required to set up an root/administration account and password.
You can put nothing and then you create a user account, using the sudo command as you explained.

I have no problem apart when I try to run the ‘root terminal’

And also when I try to run the software in graphical mode of my vpn, my user password is not working (I install it using the sudo command with no problem).


#4

It’s a Wayland bug, there is a workaround:


#5

Thanks for your help, I install cinnamon and I still have the same problem…


#6

Wayland is a new graphic server to replace X11 almost all GNU/Linux Desktop are changing to it, to check if you are using Wayland type in your terminal:
echo $XDG_SESSION_TYPE


#7

indeed I’m using Wayland…
I don’t really understand how to work around that problem via the previous topic you are pointing to.
(I’m a new Linux user)
I’ve entered in the terminal : xhost +SI:localuser:root I get localuser:root being added to access control list

But it does not change anything


#8

Just type in terminal:
xhost +local:

Or you can do:
xhost +local: gparted-pkexec

To just locally add that app to the access control list (change gparted-pkexec for your VPN app) and then open the application

When you restart the computer you will have to do it again, It’s a wayland reported bug, probably they solve this shortly, or the applications will adapt to Wayland working way, because isn’t necessary for applications to use the GUI as root.


#9

this has allowed me to run the vpn application via the terminal.

Then when I use the command : xhost +local: “myvpn_name” i get :
xhost: bad hostname "myvpn_name"


#10

After poking around a bit in the man page (man xhost) and running ‘xhost’ with no arguments, it looks like the command might actually be:

xhost +SI:localuser:root

It seems to work and doesn’t spit out an error :man_shrugging:

$ xhost
access control enabled, only authorized clients can connect
INET:localhost
INET6:localhost
SI:localuser:username

$ sudo xeyes
No protocol specified
Error: Can't open display: :0

$ xhost +SI:localuser:root
localuser:root being added to access control list

$ sudo xeyes

… and then xeyes opens.

In general xhost is not the greatest thing to muck around with, it has been known to be insecure if used improperly (and probably even when used “properly”). It’s probably better that one must run this every time they want to do something crazy with sudo.


#11

That is just to run a “window” with root privileges I use it with synaptic and gparted, because that apps requires to run like that, this is a malpractice and they need to change the working method sooner or later, because Wayland just let run windows to current user.

But I don’t understand what do you need to do exactly, an VPN isn’t a program that requires interface.

Can you explain better what do you need to do?


#12

There are several reasons for me to prefer using the Vpn interface.
From various sources it is mentioned :
_Due to multiple, critical problems in network-manager-openvpn which after years have not been solved we recommend to NOT use it. _
network-manager-openvpn runs OpenVPN so that OpenVPN does not check the server certificate.
Therefore we DO NOT RECOMMEND usage of network-manager for security reasons.

Also, when using Openvpn, I can’t use for example the “kill switch” option and other setup.

Doing

has allowed me to access the vpn interface. But I have to do this after every restart of PureOs.
So the problem is partially resolved… Thanks Uzanto !


#13

You could also start the session with X11 instead of Wayland by default, because X11 still in your system.
Maybe you can send bug reports to help improving network manager.

What software are you using for VPN management?


#14

I’m using Eddie software from Airvpn


#15

I’m having the same problem with the eddie client. Are there any fixes or more convenient workarounds? It seems this issue has been existing for quite a while now and it is really annoying, because if I close the eddie client, I don’t have internet anymore. So then, I either have to restart or use eddie in order to have internet connection. All this is a lot of clicking and typing of passwords.

Any help is very much appreciated.