Saving FireFox in Activies?


I’m new to PureOS and am having a hard time saving FireFox to my Activities shortcuts. I downloaded FireFox and want to be able to click Activities and see the icon for the web browser in the Activities menu.

I’ve tried right clicking, left clicking and dragging and dropping and nothing is working.

You do not say how you installed Firefox. If you just downloaded and untarred it–I do it that way–you may need to add a firefox.desktop file to /usr/share/applications. The contents of that file is enumerated here. (You will only need to do this once.)

I also had a problem on Gnome when I received my Librem a few years ago. I hope this is fixed by now, but I figured out that there was no in /etc/xdg/menus or in ~/.config/menus. I did a forced reinstall to get that generated:

sudo apt install gnome-menus --reinstall

Good luck!

In the newest Gnome if you’ve got Firefox on the dock it won’t appear on the activities menu.

Is Gnome like Terminal? I entered this in Terminal and got an error message

[Desktop Entry]
Comment=Browse the World Wide Web
GenericName=Web Browser
X-GNOME-FullName=Firefox Web Browser
Exec=/home/firefox.bin %u

When I installed Firefox I just downloaded it and untarred it. Where do I enter the code? I tried Terminal and got an error message.

“sudo apt install gnome-menus --reinstall” … What?

I’ve been a Mac user my whole life and this is my first time using a Linus OS so bare with me lol

The .desktop is a text file.You cannot type this just in the terminal as command lines. Use VI or Nano instead and save the file in /usr/share/applications.

or perhaps better in the user’s directory for that purpose: ~/.local/share/applications

Others have offered advice on the firefox.desktop file. It is actually a file that gives system information on the applications, etc. so it can be collected by the system and presented to the user on the desktop and in the gnome menus (or other desktiop types.)

I noticed that in your enumeration there is Exec=/firefox.bin %u. That needs to be changed to whereever you have untarred firefox. For example, I untar to /opt, so mine shows Exec=/opt/firefox/firefox %u.

The command I suggested was for a bug that existed a while back…just in case it still happens to folks. (I have seen more than one person besides me have the issue.) That would be run from the terminal. ‘sudo’ provides temporary root access, so it will ask for that password. I did this a long time ago, but the intent is to actually generate that file; otherwise, the added .desktop would not show up for me. (There may be other ways to do that; I thought that was easiest for me after a hiatus from Linux.) Again, this may not be the problem.

@irvingwade offered advice for a different directory. I made my decision for other reasons, but his is more proper.

I am sorry to have made assumptions about experience and not explain more completely.