Screen sharing with Zoom, blocked by default


#1

Zoom blocks me from doing a share share, with the following message:

Can not start share, we only support wayland on GNOME with Ubuntu(17 to 19), Fedora(25 to 30), Debain(9,10), openSUSE Leap 15, Arch Linux, AnterGos, Manjaro. If your OS is not on the list, please use x11 instead.

This is zoom 3.0.29175.0908 installed via the .deb package available to download from zoom https://zoom.us/download?os=linux (I selected Linux type: Debian, OS Architecture: 64 bit, Version: 8.0+).

Does anyone know of a work around here? Despite their misspelling of Debian, it seems like our OS should be supported.

Thanks for your help!

Luke


#2

Search for version 2.9.265650.0716 that is what I’m running on PureOS 8.0 without issue.


#3

Thanks @OpojOJirYAlG are you able to do screen sharing? I can run the app and make calls, I just get this error at when attempting to screen share.


#4

Fair question, we don’t use zoom internally so I’ve never had the occasion to share my screen only to join and view someone else.


#5

@OpojOJirYAlG Would you mind testing it for me with your setup? Just start a call with no one and try clicking the share screen button :slight_smile:


#6

I just tried this in a VM. I installed Zoom’s Debian package, tried sharing my screen, and got the same error about not using a supported Wayland distro, and quit Zoom.

On a hunch, I edited /etc/os-release and changed it to have

ID=debian
NAME=Debian
PRETTY_NAME=Debian

VERSION_ID=9.0

(where previously, it said PureOS and version 8.0). I didn’t change any of the other lines. Restarted Zoom, and tried screensharing, and it worked.

So basically, Zoom doesn’t bother checking whether your system is actually capable of screensharing, it just checks if the distro name is in the list of supported distros. You can change the distro name and have it work, but I have no idea what sort of other problems that could introduce (maybe it’s harmless, maybe it breaks updates, I dunno).

If you really want/need to use Zoom’s screen sharing on PureOS, then you could edit that file every time you want to share, then change it back to the PureOS values when done.

Or you could set up a VM with one of the supported distros, and use Zoom from within that (though then you’d also need to access your presentation/whatever you are sharing from within the VM too, as it only shares the VM display, not the host display).


#7

Nice find, I get the same results on my physical system.


#8

Thanks @taylor-williamc that’s great.

I might try and submit a support ticket to get our OS added to their list, if it’s meanly a listing issue.

Otherwise, is there a way we might change how zoom interprets this setting without effecting other applications?


#9

If Zoom were open source, there would be a way, but since it’s not, I don’t think there’s anything we can do. Filing a support ticket may at least get it added to the list, or better yet, hopefully encourages them to change the checking mechanism to check whether the system can do it, rather than just checking if the OS name is in their list.


#10

:heart: thanks @taylor-williamc


#11

Even if they stick with a hard-coded list of OS names, providing a supported, documented mechanism whereby one OS can pretend to be another / override the actual OS with a different OS of your choice would be a workaround.