Screen sharing with Zoom, blocked by default

Zoom blocks me from doing a share share, with the following message:

Can not start share, we only support wayland on GNOME with Ubuntu(17 to 19), Fedora(25 to 30), Debain(9,10), openSUSE Leap 15, Arch Linux, AnterGos, Manjaro. If your OS is not on the list, please use x11 instead.

This is zoom 3.0.29175.0908 installed via the .deb package available to download from zoom (I selected Linux type: Debian, OS Architecture: 64 bit, Version: 8.0+).

Does anyone know of a work around here? Despite their misspelling of Debian, it seems like our OS should be supported.

Thanks for your help!


1 Like

Search for version 2.9.265650.0716 that is what I’m running on PureOS 8.0 without issue.

Thanks @OpojOJirYAlG are you able to do screen sharing? I can run the app and make calls, I just get this error at when attempting to screen share.

Fair question, we don’t use zoom internally so I’ve never had the occasion to share my screen only to join and view someone else.

@OpojOJirYAlG Would you mind testing it for me with your setup? Just start a call with no one and try clicking the share screen button :slight_smile:

I just tried this in a VM. I installed Zoom’s Debian package, tried sharing my screen, and got the same error about not using a supported Wayland distro, and quit Zoom.

On a hunch, I edited /etc/os-release and changed it to have



(where previously, it said PureOS and version 8.0). I didn’t change any of the other lines. Restarted Zoom, and tried screensharing, and it worked.

So basically, Zoom doesn’t bother checking whether your system is actually capable of screensharing, it just checks if the distro name is in the list of supported distros. You can change the distro name and have it work, but I have no idea what sort of other problems that could introduce (maybe it’s harmless, maybe it breaks updates, I dunno).

If you really want/need to use Zoom’s screen sharing on PureOS, then you could edit that file every time you want to share, then change it back to the PureOS values when done.

Or you could set up a VM with one of the supported distros, and use Zoom from within that (though then you’d also need to access your presentation/whatever you are sharing from within the VM too, as it only shares the VM display, not the host display).


Nice find, I get the same results on my physical system.

Thanks @taylor-williamc that’s great.

I might try and submit a support ticket to get our OS added to their list, if it’s meanly a listing issue.

Otherwise, is there a way we might change how zoom interprets this setting without effecting other applications?

1 Like

If Zoom were open source, there would be a way, but since it’s not, I don’t think there’s anything we can do. Filing a support ticket may at least get it added to the list, or better yet, hopefully encourages them to change the checking mechanism to check whether the system can do it, rather than just checking if the OS name is in their list.


:heart: thanks @taylor-williamc

Even if they stick with a hard-coded list of OS names, providing a supported, documented mechanism whereby one OS can pretend to be another / override the actual OS with a different OS of your choice would be a workaround.

This worked to enable the screen-sharing button in zoom for me, but now I’m noticing that not all of my application windows get shared properly. E.g. sublime text and tilix do not show up in the video feed when I enable screen sharing. It’s like they just don’t exist. Any idea what’s going on here?

I notice something similar when trying to screen share from a browser with or google hangouts. In Chrome, if I choose “share entire screen”, the entire screen I share is black, except for my mouse pointer. I am able to successfully share the location of my mouse, but that’s it :stuck_out_tongue:

Sharing a browser window seems to work, but I can’t share any other application windows, and I can’t share my entire screen.

I’m not an expert, but this might be some security mechanism in Wayland. It would be worth checking if you see similar behavior when using an X session rather than a Wayland session. You can switch between them when you login by clicking the gear icon at the login screen.

OK, I am using PureOS with Wayland since >3 years, and I definitely used Zoom. I remember having experienced some problems with screen sharing initially, but thought that had gone away. Now I also get the message that my OS is not supported.

So it seems that Zoom is simply checking the names in /etc/os-release - could it be that previously (e.g. in the “Rolling-Release” days) it did say something different in /etc/os-release, which made Zoom happier?

I can confirm that editing /etc/os-release makes the blocking message go away, and it says that I can share the desktop or the whiteboard. Desktop sharing worked. I can not choose individual windows, but that may be a feature which is not available in the basic account. However, while I could see annotations drawn on the shared desktop from the remote participant, he could not see my annotations. Could that be a problem/feature of wayland?

I am using Zoom version 3.5.392530.0421, which is the current Ubuntu 14.04+ version on the ZOOM Download Center. It seems that different versions behave differently (it is interesting that the Debian version number seems to be 3.0xxx).

You were right @taylor-williamc! Screen sharing works fine for me when I use an X session.

1 Like

I just logged into my Librem 14 with X11 rather than Wayland and zoom sharing works just fine now. I can’t believe I went through such rubbish (I even switched to Ubuntu for a while!) just for zoom screen sharing when this solution was staring me in the face the whole time - I didn’t know what “use X11” on the zoom error message meant.