Second SSD Access/Permissions


#1

Upon opening my Librem 13 for the first time, I am able to ‘see’ the secondary drive in PureOS, but I cannot access it. It allows me to mount it, but tells me I do not have permissions to write to it. Any ideas on this one?


#2

Hi @privy,

What kind of drive do you have?
What filesystem do you have on your drive?
Does mount output anything when you try to mount that drive?
What is the output of cat /etc/fstab ?


#3

It’s a standard Samsung SSD that comes with the Librem 13. Here’s my output:

$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use ‘blkid’ to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
#
/dev/mapper/crypt-root / ext4 errors=remount-ro 0 1
# /boot was on /dev/sdb2 during installation
UUID=4164808b-4020-4a26-ae1d-ba350a4c862d /boot ext4 defaults 0 2
/dev/mapper/crypt-swap none


#4

During installation, the main SSD Drive was encrypted and used /dev/sdb, and it looks like /dev/sda is the one I cannot use.


#5

Hm… I must state my incompetence in helping you with this one unfortunately.

Have you tried to format it without encryption, in order to determine whether it’s a hardware issue or not?


#6

I have not, but will try. Thanks.


#7

Doing this isn’t necessary.

First, run sudo fdisk -l in your terminal. On PureOS the terminal is called tilix.
The output should give you an entry that says something related to LUKS (I’d give you an example but I have no drives currently). Let’s say the encrypted SSD is /dev/sda and the second SDD is /dev/sdb (you’ll need to find this information out with the fdisk command). We’ll start by adding a place to mount the drive, say /media/ssd. We can do this by running sudo mkdir /media/ssd. Now that the directory exists, we can mount the drive. Assuming the drive is already partitioned (this can be found by looking at the fdisk -l command output), we can mount that partition. To mount the first partition (most likely the one you’ll use) we’ll run the command sudo mount /dev/sdb1 /media/ssd. The 1 after /dev/sdb denotes which partition to mount. If you wanted to go a step further, you could mount the drive in a folder in your /home, allowing for easy access.


#8

I’ve tried to format the extra drive without encryption, and I’ve tried mounting it. The mounting works fine, it’s just I get a permissions issue whenever I try to write to it.


#9

Ah, that’s easy to fix. Simply run sudo chown -R $USER:$USER /mountpoint with /mountpoint being the path to where you mounted the drive.


#10

I believe the long-term fix you want might come from this question on stackexchange:


#11

This worked, thank you very much everyone for the help.


#12

@privy, glad something worked for you!

Could you mark the post that helped you as an accepted solution?

See in the screenshot below how to do that.