Setting static IP address on PureOS

I’m still really green to Linux so I’m not too comfortable just “playing around” with it.

My question is:

Where is a user friendly Linux tutorial for newbies, to show step by step how to turn a PureOS workstation into a DHCP server temporarily?

I need to do this to setup an Edge Router that I ordered for a brand new network.

I tried the following on both port 0 and 1 on the Edge Router,
“Configure host system with a static IP address on 192.168.1.x subnet.
Launch browser, type

Returns an error of, “Unable to display this website
The site seems to be unavailable.”

Likely from not having configured a subnet.

I also have not yet looked into how to use the “console” port, but am open to resorting to that option if I must.

I have decided to request help from PureOS as this is the OS I’m on, and requested help from Ubiquiti as this is the router I’ll be using. These are the two products I’m working to setup my new network.

I think this Edge Router requires me to actually link it to a DHCP server, but I have no server. I have only this PureOS laptop. How do I spoof a DHCP dynamic or static DHCP server while operating exclusively from a PureOS workstation desktop?

1 Like

I interpret that to mean:

  • Neither device is dependent on or should be using DHCP.
  • The network equipment just comes up with a static IP address of but allow a few minutes for it to boot fully as some of this equipment is fairly leisurely about booting.
  • You have to configure your laptop (desktop) with any static IP address that is in the right range - where the right range would be 192.168.1.x where x is in the range from 2 to 254 (and hence many people would just use The assumption is that you give your laptop (desktop) a subnet mask of and that should be it.

Once you’ve done that … forget about web browsers for the moment. Just go to the shell prompt and type


If you get good ping responses then start the web browser. If you don’t get good ping responses then start troubleshooting.


I searched for, “How to create subnet mask of Linux” and there is nothing about PureOS. I have seen tons of examples for Ubuntu and even then they still download the Server Edition or package updates for networking on Ubuntu.

I think the confusion here is from too many assumptions being made due to my lack of being clear, so let me clarify a bit more.

  1. currently I have no internet access / this is a local LAN until later

  2. the instructions on the Edge Router website mention either or methods. By use of either DHCP or use of a static IP address method.


At this point I don’t even care anymore, I just need it to work. I had a preference for DHCP so to avoid the security and privacy risks of a static IP solution. At this point I no longer care anymore, I will throw all security and privacy out the window just to at least get this operational. Besides it is currently offline, so I will deal with securing it later after it is functional. Though I had hoped if I did DHCP now I wouldn’t have to reconfigure it later, but again I don’t care anymore so if I have to use a static IP then so be it.

“Once you’ve done that … forget about web browsers for the moment. Just go to the shell prompt and type
If you get good ping responses then start the web browser.”

This is wonderful to realize, thanks for the pro tip! I assume from the “shell prompt” you mean my workstation “terminal”? Just trying to communicate clearly.

I still have no idea what I am doing, as I have found no directions yet through Forum searches, web searches, or video searches on how to “create subnet mask” using PureOS. Please kindly point me to where I need to be looking for this. I need a guide. I understand this maybe too much to ask as a Forum reply, which is why I am requesting a guide already written somewhere.

Thanks for your initial response, as it at least gives me an idea of where to search for now. Even though I remain completely lost still.

1 Like

(with the disclaimer that I don’t have that network equipment to try out)

In that case, go with the Edge Router’s second-documented method i.e. static IP address.

The key point seems to be that you must use the port labelled “eth0” on the Edge Router when using the second method. Don’t try both ports on the Edge Router. Just try the port that they are telling you to use.

Have you successfully set the static (may be called “manual”) IP address on your laptop (desktop) to ?

When you get there to do so you will probably be asked to enter three things: IP address, subnet mask (may be labelled “netmask”), gateway IP address.

You would enter and and respectively.

The gateway IP address will not be used but the UI may not be happy unless you enter something, so I am giving you something to enter that should be relatively harmless.

You are better off looking for examples for Debian. Ubuntu and PureOS are both, independently, derived from Debian.

Yes. Terminal.


I don’t know how to do that in the PureOS UI, I also do not know how to do that in the terminal command line either on Linux without following some kind of instructions.

Thank you a ton btw!!!

1 Like

Do you have any kind of Settings icon?

I don’t recommend attempting to do the whole job of configuring a static IP address from the terminal.


I didn’t notice one

Let me reboot my laptop, and look around again in PureOS UI

(I’m using my laptop with PureOS to directly connect to this router for this. As soon as it works I will be working this way to setup the network permissions such as closing and opening the ports, because once I get past these first steps the router will finally show an UI in the browser so I can deal with it from there but I am no where near that step yet)


1 Like

How about ethernet icon on top line of screen on right hand side?


So I am at,

“Activities” > “Settings” > “Network”

Within the “Network” tab the toggle keeps turning blue and gray / off and on as a periodic error keeps flashing as a notification on top screen “Connection failed: Activation of network connection failed”

It also reads showing, “1000 Mb/s”

What do I do? Where do I go?

1 Like

I also try clicking “Advanced Networking Configuration” and a window appears

It shows “Ethernet” and under that it appears “cwiredin” and beside it it reads “never”

1 Like

That’s because the computer is trying to use DHCP. That will go away once you get it configured for a static IP address.

Click the cog icon at right hand side of your ethernet device.

Then click the IPv4 tab.

Then choose the IPv4 method - probably the choice that you want is labelled “manual”.

Does that get you far enough?


Sorry just now trying to click around more. So in the “Network Connections” window there is a settings icon, I click that and I have opened now “Editing cwiredin”. I see there is a tab for “IPv4 Setting” and opened that. It looks like this is where I can input the DHCP stuff?

1 Like

Will try this now brb

1 Like

Well except you are trying to use the opposite of DHCP. You are trying to set a static (manual) IP address.


I have entered the address to identify my laptop in the field under the “Address” input within the “IPv4 Settings”

Not sure what else to do, but there is now a green light on my router Ethernet so I will try to ping test like you gave directions earlier

1 Like

Yes I have settled for the static IP method lol thank you btw

entered:~$ ping

ping: connect: Network is unreachable

(also Forum is now saying I must wait 22 hours to issue anymore replies :frowning: )

1 Like

Based on that screenshot you have butchered it.


However you are getting closer!


@JCS is there some way to override this for this user, at least temporarily?


newuser max replies per topic = 3 → 5


Yes that worked!


Wow you are amazing thank you so much for holding my hand through this