Sharing service not installed

This topic was originally addressed 3 year ago but no definite solution was proposed. Hopefully some new ideas may pop now. Folder Sharing Service Not Installed

I am trying to establish a network connection for file sharing between my newly installed PureOS computer and my main Windows 7 home network. I’d like to be able to share files back and forth between those two desktops. The Win7 computer has a shared folder with public read/write access rights. And I can easily share files between all my Win7 computers.

From the new PureOS computer I can successfully ping the Win7 computer and vice versa. In PureOS I installed smb4k and I verified that smbclient is installed by this line:

sudo apt install smbclient

To which I got a message back stating that sbmclient is already installed.

From PureOS Files I can now see a Windows Network in +Other Locations. Yet, clicking on
Windows Network will show an empty window. I Cannot see my Win7 computer.
Using Files navigating to a folder, I can Mouse Right Click and choose Sharing Options. I then get a message: Sharing service is not installed. I choose Install Service then I get another message box:
Sharing service installation failed / Would you like to retry the installation?
And that is the end of the tunnel.

I spent countless hours in the web trying to find a solution without success. I found many posts stating that same problem but found no definite solution. The fact that I can ping both computers is a sure sign that PureOS can access the network. I have a feeling that I am missing a very simple detail to get this Network access to work. In the previous post, cordellsr states that he got his Network access to work but didn’t know what he did to get there. So, surely, there is a solution.

Hopefully some of you will have insight to that problem. Thanks anyone. Cheers


It almost sounds like “M$ Active Directory” stuff. Which I stayed away from and let the company Admins handle it because I could never wrap my head around it. If I can’t do it chmod I leave it alone.

1 Like

Did you try connecting to it using smb://IP address/name of share?

Problem Half Solved
Here is what I entered: smb:// and it Worked ! thank you so much you made my day. :smiley:

However it only work one way. I still cannot see my PureOS shared folder from Win7 Network computers list from the Windows Explorer.
Lets not forget that I get an error: ___ Sharing service installation failed ___ when I try to share a PureOS folder. Have you got another magic trick to suggest. That one was great. :wink:

Try launching Nautilus like this from a terminal
G_DEBUG="all" NAUTILUS_DEBUG="All" nautilus

You should be able to see what’s wrong.

As a beginner with Linux I’m not too sure what you are attempting here but this is the result:
A second Files window opened in PureOS, nothing more, no notification, no text or explanation of any sort. And I still cannot see my PUreOS computer from Win7. Can you please elaborate a little on the goal of this intervention ? thanks

He probably meant for you to install the service with Nautilus in debug mode so we could troubleshoot.

OK. So Nautilus is the Files program. I get it. So now I should have Nautilus or Files in a debug mode. And now I will redo the sharing attempt and should get more information. Is that the idea ?


I also saw on a ubuntu forum that you should have samba installed (in case it isn’t) with:
sudo apt update && sudo apt install samba

I did install smb4k which is the window interface including samba (from what I understood).
I just tried to share a folder with a new instance of Files and its the same result. I still get the same error message Sharing service installation failed and Files did not change a bit, even is Debug mode. Its as if G_DEBUG="all" NAUTILUS_DEBUG="All" nautilus __ did not change anything.

Take a step back.

  1. When you want to make files available from Windows to Linux then you need to have a Samba client installed on Linux - and you may get that by using nautilus (Files) - and if it’s not working, you may want to enable debugging in nautilus.

  2. When you want to make files available from Linux to Windows then you need to have a Samba server installed on Linux. It seems like nautilus is (un)helpfully offering to do this for you - but nautilus itself plays no role in it - and in any case it doesn’t seem to be working.

When I have used Samba server, I have always done this by installing and configuring a Samba server from the command line (using root access i.e. sudo).

There are two things that need to happen for Samba server to work.

a) it needs to be installed and running
b) a share needs to be defined

For the first part, you want

sudo netstat -antp | grep smbd | grep LISTEN

to show something like

tcp 0 0* LISTEN 9876/smbd

(The 9876 is the process id and may be whatever number, different on your computer. The 139 is important. It will be either 139 or 445 or both.)

Once that is correct, for the second part, you need to edit /etc/samba/smb.conf in order to define the share that you want to make available to other computers but unfortunately there are a lot of settings and yet you probably only need to set a few in order to get it working.

Bear in mind that making a folder available to other computers is a permanent change (will persist across reboots), so if you are doing this for some temporary purpose, remember to disable it afterwards.

In case it helps, yes, on Windows you can map a share using IP address, and that will bypass some of the possible problems. That is the approximate equivalent of the suggestion above at: Sharing service not installed so on Windows, within the Windows Explorer thingy, you would map the drive as \\IPaddress\share

In either case, client or server, there are too many things that could be going wrong to say for sure what is going wrong. Could be wrong workgroup name, could be host name resolution, could be incompatible security settings, could be firewall, could be wrong port.

For someone to really help you, they would need to have Windows 7, or at least Windows of any version. So that counts me out.


Disclaimer: I’ve never shared an ext4 folder with windows, so I don’t know if it’ll work (assuming that’s what you have since you’re sharing from your computer).

This is what I did from a raspberry pi:

Change your shared folders permissions to nobody and nogroup - sudo chown nobody:nogroup /path/of/share

Open samba config - sudo nano /etc/samba/smb.conf

Scroll down a bit to global settings. If your workgroup name is something other than “WORKGROUP” then change it here, otherwise don’t worry about it.

Just below that is a commented out line that says “wins support = no.” Uncomment it and change “no” to “yes.” WINS is kinda like network DNS that windows uses.

Scroll down a little, and just before the Networking section add a line that says “guest account = nobody”.

Scroll down to the bottom and add a section that has the following -

path = /path/to/share
public = yes
writeable = yes

Save the file with Ctrl+X, then Y, then enter.

Restart samba - sudo service smbd restart

That should be all. Note that anyone in the network will be able to read and write to this directory with this setup, which is something I wasn’t worried about.

Info is a bit old but worked for me last year. Hopefully its still relevant. It was taken from here:

Thanks kieran, Here is what came out after trying your suggestion.
dg45id@DG45ID:~$ sudo netstat -antp | grep smbd | grep LISTEN
[sudo] password for dg45id: [ here I entered my password ]
Absolutely nothing came out
dg45id@DG45ID:~$ sudo netstat -antp | grep smbd | grep LISTEN
So much for that attempt. However, your explanations did shed some light in my understanding for the OS. Appreciate.

Thanks Gavaudan, Very helpful answer. But not without some fiddling. I found out that smbd was not installed. So, I navigated to the Raspberry instructions and installed smbd (desbite the fact that I have smb4k installed) . Anyway, after installing smbd and restart I am now able to see my DG45ID computer in Win7 Network. Great stuff !

Now, my Windows Workgroup name is MAISON. Samba.conf was correctly edited to reflect that name. Yet, when I click on the DG45ID computer in Win7 Network I am required to supply Name and Password to get access. I notice that the Domain shown in the window is different than MAISON. In fact, it is the name of the Win7 computer all in capital: INDIGOPC. I’m I correct in the assumption that Domain = Workgroup ? If so, why is the Domain name in the access window not MAISON ? And, if I enter the user name and password (from Win7) these name and password do not work. Is this access refusal caused by this Domain discrepancy ?

My progress is encouraging. I can now get files from PureOS from Win7, I now can see my PureOS computer in the Win7 Network, but I have this password name domain discrepancy.

Gee! I am almost there. How could this be rectified ? Much appreciation :smiley:

I will try to shed a little light on this. I can’t answer all of your questions, but I will try my best.

No, Workgroup and Domain are not the same thing. Unless you have a domain controller set up, and your computers are all members of that domain, you are not on a domain. Windows is defaulting to your current user on your Win7 machine. It is showing INDIGOPC (the computer’s name) as the domain because that user is local to that computer.

The username/password it is asking for when you try to connect is actually a username/password for a user on your DG45ID machine. This user will need to have access to that directory. If memory serves (I may be wrong on this, it has been awhile) those permissions are defined in your smb.conf file.

As far as what you should put as the domain when providing that username and password, I am not sure. You can try leaving it blank (if possible), or try DG45ID, as that user would be local to the DG45ID computer.

I hope that makes sense.

Thank you CyborgPenguin, makes a lot of sense.
Eureka, I got the solution. I found a great hint on unix about smbpasswd setting . Here is the solution:

For each user account you would want to be able to access the samba share, do this on the server:

smbpasswd -a dg45id

It will then ask for a samba password.

I did just that and was able to get access to my DG45ID computer from Windows INDIGOPC.
I now have complete access to all Shared folders.
It took many fiddling and attempts but now I’m in business.
A big thank you to everyone of you who got involved in this question. Much appreciation for your help.

1 Like