Signal app now usable in portrait mode on L5

Hi Tom,

I got exactly the same dialog. I don’t know what that is either.
The only thing that ultimately helped was typing into the text field the exact example URL that the dialog suggested.

1 Like

If I remember correctly, in the same message to supply a mirror, it gives you an example for a debian mirror domain. I’m pretty sure I used the same domain and that worked for me.

Keyboard Snag After Updating

Just a quick warning - after testing the new keyboard for another day, I’ve notice one snag. In Terminal (when using nano in this case), the keyboard was not recognising the ALT+X commands to save, etc. In order to get that to work, I had to pull up the screen that shows the “ESC” key, press that and then try to do the ALT + X commands again - and it doesn’t always work, you may need to try it a couple times which is less than ideal. Also, you need to make sure you used the capital version of the character, etc. So yeah, unfortunately it does seem to negatively effect terminal input.

Perhaps @dos may want to update the fix to account for that? Or at worst, keep the “Terminal” layout working using the old system and all the other standard layouts using the new one? Just a suggestion

1 Like

Exactly. That’s what I meant to say. Thanks for clarifying!

Ok, you might be running into issue squeekboard!373 (explanation).

1 Like

Yep, just noticed that @Dos mentions it under your post. :slight_smile:

Hopefully they can figure out a solution and fix both at the same time.

1 Like

For the record, all you need to get the command to register anyway is to toggle the modifier back and forth after pressing the key and then retry. It’s just really annoying :crazy_face:


Haha, indeed it is!

When trying to edit a file in nano I couldn’t get it to work that way, I had to go into that little screen where the ESC key is and after pressing escape it would allow me to “lock” the alt key first before trying (worked around 50% of the time lol). It seemed I had slightly better luck that way so I don’t know if that helps with the fix at all but thought I’d share :slight_smile:

In any case, great work so far on the input fix for Chromium-based apps. It makes me not want to throw myself over a cliff when using Signal, haha. Seriously, that alone is making the Librem5 a waaaay more productive device for me because it’s reconnected me to my social circle!

If we can nail that final snag with the Terminal we’ll be golden! :slight_smile:


@dos, thank you for your help. Now that i am past the mirror for pbuilder,
are these the correct instructions for installing Signal?

sudo flatpak remote-add --title=‘Signal Desktop’

sudo flatpak install signal org.signal.Signal

Thanks, Tom

Video calls do not work yet on L5, camera needs better integration other than just the Dev Camera application.

You also have to add the Flathub repo as it contains the necessary runtimes needed to install signal:

flatpak remote-add --if-not-exists flathub

I run these before the other commands ?

Like this:

flatpak remote-add --if-not-exists flathub
sudo flatpak remote-add --title=‘Signal Desktop’
sudo flatpak install signal org.signal.Signal

OR like this :

flatpak remote-add --if-not-exists flathub
sudo flatpak remote-add --title=‘Signal Desktop’ signal
sudo flatpak install signal org.signal.Signal


I honestly don’t see the difference between the two. But from what I see it looks correct. So long as you have both repos added, then you can run the command to install signal.

just to let you know, you do not need sudo when installing or uninstalling flatpaks since they do not require root access. That’s one of the benefits of using flatpaks :grinning:

Thanks, I’ll give it a shot. Tom

I got it installed (I had to use the second version of the commands) but the window is divided vertically and impossible to use. The drop down menus do not work either.

I plugged in to an external monitor to go to File → Preferences → General → Zoom Level → 75%

Then it might be more usable :man_shrugging:

EDIT: Tapping the gear icon also opens the settings, so you might not need a different monitor.

Oh yeah. The first time you open Signal it will do that. You don’t necessarily need to plug it into an external monitor to fix it.

If you have a bluetooth mouse or a USB-A to USB-C adapter to plug in a mouse, you can drag the conversation list window to make it smaller and make it more readable.

Also to enable the 75% scaling in settings you can open the settings and then put it into landscape mode to see the option you want.

After you have done that once it will remember from then on.

1 Like

That should no longer be necessary in the latest flatpak because the conversation list width is now automatically pinned to a minimum.

1 Like

I reduced the display scale in Signal down to 75%, but now the keyboard will not type a message into the message window. So far this is very buggy.

So, where talking Signal desktop here. Is it preferable over Flare?

is this the same app that is on offer on the official Signal website? (I’m guessing it is not. So what is the difference?) Should I go for this one, or for the one available on the Signal website?

Flare is no good, me thinks.

Why is it so ff’n hard to get a decent, non-commercial chat app for a phone like the L5?!