Signal app now usable in portrait mode on L5

With the latest fixes landed in Adam Thiede’s flatpak repository, you may want to give the Signal app another chance – it’s working on the L5 in portrait mode now:


If you don’t have the Signal app installed, add Adam Thiede’s Flatpak repository first:

sudo flatpak remote-add --title='Signal Desktop' \

To install the app, run:

sudo flatpak install signal org.signal.Signal


If you already have the Signal app installed, try updating it to v6.30.1:

sudo flatpak update org.signal.Signal

Enabling HiDPI

Optionally, if the app appears blurry and pixelated to you, run the following command line as a workaround (requires the desktop-file-utils package):

desktop-file-install --dir="${HOME}/.local/share/applications/" \
    --set-key=Exec \
    --set-value='flatpak run org.signal.Signal '`
        `'--enable-features=WaylandWindowDecorations '`
        `'--ozone-platform-hint=auto' \


Then restart the Signal app. It should now be using Wayland and appear in proper HiDPI resolution.


I mentioned this the other day on an older thread, but since you were kind enough to make a new topic relevant to it I shall add it here.

In Signal Desktop app settings there is now the option to scale the chat window down to 75%, which, in my opinion, makes it even more friendly for portrait viewing

1 Like

In Signal Desktop app settings there is now the option to scale the chat window down to 75%, which, in my opinion, makes it even more friendly for portrait viewing

I agree.
A zoom level of 75% is necessary for the emoji overlay to have a working ellipsis (…) button.

Do these flags work better? If so I will replace what I have on the site with this.

Also I am glad this continues to be useful for you. The fixes were implemented by a contribution, not by me.

As I don’t use Signal anymore, I won’t know when things are broken. If you do have bug reports or issues, please add them to the repo so that at least someone can try to fix it!


Thank you for continuing to maintain the flatpak repo. It is greatly appreciated!


Definately appreciate the work that has gone into this. However, is anyone else getting a few strange bugs with the on-screen keyboard?

When typing messages, a few of the characters on the on-screen keyboard don’t work. I believe it is Q and K.

I believe it works if connected to a keyboard but that isn’t really a fix for trying to use my Librem5 as a daily driver. Any fixes / suggestions would be great!

1 Like

Can confirm. It has been that way for many releases.
However, it’s different keys for me, maybe due to German keyboard.
Works fine with external keyboards as you suggested.

My workaround for now is to rephrase my messages to avoid affected letters. That’s not a good long-term solution either.

1 Like

Haha, yeah same.

One half-workaround I found is if you press the “globe” button on the keyboard you can select the “Terminal” setting for the keyboard which pushes the keys down. This will allow Q and K to work but will make other keys broken instead, lol. Then you’d need to switch back again.

It is just about workable but really is painful. It seems like if we could nail this last glitch Signal would be more or less good to go!


I can confirm that in Spanish n, w, y, ñ, V, é, Í, ú don’t work and that ó works as “home” key in the line. I haven’t tried all the keys, so probably there are more bugs

1 Like

I haven’t had any problems with the “Q” or “K” keys on Signal. The only problem I have is with capital “C” where it basically acts as a backspace. This is for default English US keyboard

interestingly, my capital C works fine. but if I turn on caps, the Q and K characters work and some others don’t. Pretty crazy bug, lol.


I think the missing letters issue with the OSK happens on Wayland only. See here several other issues.

I can use all letters when not running using Wayland for the flatpak.


just tried this by removing the wayland arguments from desktop file. Confirmed all keys work except capital C which now works like a backspace, lol.

And of course things are a lot more blurry :slight_smile:

EDIT: After testing more, Ive found this to be worse on balance so I reverted back. attachments now crash the app, and the app is blurry. Looks like the issues were reported some time ago so shame there is still no fix yet…

As far as the ceyboard is concerned, here’s the suggestion I was given:

1 Like

I’m not entirely sure but looking into this issue on squeekboard: “Make sure Electron applications receive correct input”, it appears as though @dos may have already fixed this here.

Did I understand this correctly to be a temporary workaround for the Chromium bug that would fix the Signal (and other Chromium related) input issues? I’m assuming this hasn’t been rolled out yet?

Perhaps @dos would like to shed some light on this as I’m a little out of my depth :slight_smile:

1 Like

Good find! The MR hasn’t been merged yet or included in a release.

I just tested the proposed change and found it to work flawlessly on the Signal Desktop flatpak.



Awesome! :slight_smile:

Now if you wouldn’t mind showing us noobs the steps you used to test it that would be equally appreciated! :slight_smile:

EDIT: Just realised your link pointed to instructions! Haha, my bad.

Btw, you might have to install the devscripts, git and git-buildpackage packages before you begin following the steps from the merge request:

sudo apt update
sudo apt full-upgrade
sudo apt install devscripts git git-buildpackage
1 Like

Confirmed that input is now fixed (with the US Keyboard layout at least).

Hopefully this doesn’t break anything when the real update is rolled out later! :slight_smile:

Great work @dos , this actually makes essential apps finally “work”!


Hi, I am relatively new to Linux and just received my L5.
I wish to install Signal so I can talk and text over WiFi.
I ran:
sudo apt update
sudo apt full-upgrade
sudo apt install devscripts git git-buildpackage

But now I have a screen that is looking for the default mirror for pbuilder.
I dont know what that is and the terminal does not seem to accept any inputs.

Can you help?
Thanks, Tom