Snapd update to get beyond 2.37?

Hi, I am trying to install an app via “Snap”. The particular app is not available in Flatpak. I can get Snapd 2.37 installed, but I cannot get it to update to a newer version (I need at least 2.43 to run this particular app I am after). When I run “apt update” I receive the following errors about downloading the updates:

Hit:1 stable InRelease
Err:2 buster InRelease
403 Forbidden [IP: 443]
Hit:3 stable InRelease
Get:4 amber InRelease [5,784 B]
Get:5 amber-security InRelease [5,845 B]
Get:6 amber-updates InRelease [5,843 B]
Reading package lists… Done
E: Failed to fetch 403 Forbidden [IP: 443]
E: The repository ‘ buster InRelease’ is not signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I was asking on another forum about the issue and they were talking about Buster being too old, and needing to get Bullseye to get snapd version 2.49. I am lost at this point, as I have no idea how to work this update issue. I have tried searching around but the only suggestions I can find are to simply run an update command, and everything magically works out somehow… which obviously hasn’t worked for me.

I’m all green to linux and the terminal and try to learn what I can but it’s really hard to do this such a piece-meal fashion. I wish I had the time to learn the foundations of everything but computers are not my full time job. I just want to get the e-foundation installer to set up a couple of phones.

Any thoughts from the Pursim enthusiasts?

Thank you!

What version of PureOS are you running? Amber or Byzantium, and what is the application in question?


I’m on release 9.0, Amber.

I am trying to get the e-Foundation Installer, called “Easy Installer” on their site. It’s an OS for phones.


It looks like you have a repo for the Brave browser installed, which doesn’t seem to be working for whatever reason. This is unrelated to the installation of the snap you are trying to access but is preventing you from being able to use apt to accomplish anything. You may want to try to remove Brave browser and try to continue without it. Looking at this going backwards that would be something like “sudo apt remove brave”, and then “sudo rm /etc/apt/sources.list.d/brave-browser-release.list”. Then run “sudo apt update && sudo apt upgrade”. To continue forward with troubleshooting the e-os installer.

Ok, I’ll work towards cleaning things up. I use Dissenter and Brave as my browsers, so I’m sure they are on my system. However, when I try to uninstall the following appears (I tried a snap removal of Brave just out of curiosity).

jafra@botbot:~$ sudo apt remove brave
Reading package lists… Done
Building dependency tree
Reading state information… Done

No apt package “brave”, but there is a snap with that name.
Try “snap install brave”

E: Unable to locate package brave
jafra@botbot:~$ snap remove brave
snap “brave” is not installed

So, I’m not quite sure what is going on. I have Brave installed, but the command can’t find Brave.

So Brave installed once from the added repos, but those repos are not working. (we see not signed, perhaps a key was used at install that is no longer signed?) No apt package is about right, because local apt sees no brave with no connection to the old sources!

DONE! I tried a bunch of stuff, but here is what ultimately solved my world’s problems.

I went into the Software and Update Centre. In there, I assumed the “Other Software” section was just a list of items outside of the “PureOS Software” section, for clarity, as in the other stuff on the computer. All the Other Software items have always had checkmarks beside which I thought meant they were installed and active. I noticed the line with the Brave bad actor… so I highlighted the line and hit remove. I went back into the terminal and ran the update command, and everything went ahead smooth, no errors. Snap updated to the newer version, which allowed me to then install my desired snap app. A few reboots thrown in to recognize the new version of Snapd as well.

When I selected the line with Brave in it to delete, I received a pop-up notice that it was old/outdated, which makes sense. The active Brave browser never did disappear from my desktop, so that line was just some junk from a previous escapade.

Whew. Big thank you to everyone for their tips and thoughts. They all helped to get my head around what was happening.

1 Like

For the record, it’s brave-browser.

Good catch Gavaudan!

1 Like