issues on byzantium?

Is anyone having issues getting to work on PureOS (Byzantium)? It may actually be a “Linux” issue in general, but not sure.

I’ve tested on a range of browsers (epiphany, firefox, brave, etc ) and all are able to discover the other macs / PCs on my network but I cant send files or messages from / to my Librem13.

On the same network, the PCs and Macs are able to send files ( and detect the Librem), but can’t send to it. Is PureOS somehow set to block these kinds of connections by default? Am I missing something obvious?

Any thoughts welcome :slight_smile:


Do you need to create firewall rules to allow what you’re trying to do?

Not as far as I know. Snapdrop is supposed to be an open source version of Apple’s Airdrop feature.

It’s a webpage that allows you to share files between computers on your local network. I didn’t have to configure anything at all on the PC / Macs.

BTW: it says it is built on the following:

I thought they were just standard web technologies. Does anyone know if there are any known issues with any of the above on Linux?

@Gavaudan’s question is still valid … do you have a firewall enabled on the Librem 13?

(More recent versions of Windows will most likely have a firewall enabled out-of-the-box but the “installer” might be automatically punching holes in the firewall - and it might be that that does not automatically happen on Linux.)


No, I don’t have any custom firewall rules on my laptop, everything is open. Same for the other computers on the network.

There isn’t actually an installer, its essentially a webpage (can also be saved as a web app ) that allows computers and phones on the same local network to see each other and send files / messages. No logins, no database, etc. It can also be self-hosted (which is something I would do for extra peace of mind if I could get it working in the first place lol).

The discovery part works, as the librem can see the other computers and the other computers can see the librem, but it fails specifically when trying to send anything which makes me think that perhaps there is some issue with one of the web technologies used on linux ( or maybe a setting I’ve missed somewhere? ). The other computers on my network appear to be working fine.

There were some security concerns with WebRTC. Maybe it is getting disabled. I know it’s a horrible thing to ask but have you tried Chromium or Chrome?

Ah, was WebRTC stripped out of the linux browsers then? I’ll try and dig into that.

Haha, it is a horrible thing to ask, but just to rule it out I did test Chrome and Firefox and unfortunately experienced the same outcome… Uninstalled right after! lol

You don’t have firejail installed, do you?

Nope. At least I didn’t knowingly install it, lol.

Tried to test if it exists on my system by typing:

“firejail --list” and I get a “firejail: command not found” output in terminal.

Let me know if I’ve done something wrong there. I’m still relatively new in Linux :slight_smile:

It was a long shot. Firejail is app sandboxing software, but isn’t default on pureos.

I’ll try snapdrop out later today on my linux machines and see if it isn’t helpful. It may not be, they’re both arch-based, but we’ll see.

Appreciate it, if anything it will help to narrow down the issue :slight_smile:


In Firefox I think it’s still there (but I have it disabled). In Firefox go to about:config and choose the preference media.peerconnection.enabled and see whether it is true or false.

Hi @irvinewade,

Thanks for your suggestion :slight_smile:

I installed firefox again just to double check. The setting was already enabled and the same results are still happening. Again, it seems that pretty much all browsers are working on my network on windows and mac, its just failing specifically on my Librem13.

If anyone has any luck getting it to work on PureOS ( or even any other linux distro ) that will at least help us figure out if its an issue local to my machine or an incompatibility with Linux / PureOS in general.

The link in your second post says that Progressive Web App is not supported by Firefox on desktop (and by that I would take it to include Firefox on laptop).

Good catch, I didn’t notice that.

However, I have also tried Brave, Gnome browser and Chromium on PureOS with the same results which is quite strange.

I remembered my promise, sorry its late.

I have two arch-based distros on two machines (manjaro and garuda). First I used two Firefox derivatives. When I tried to send either a file or a message, it failed, but I did see the browser on the other computer blink, so it received something but it just didn’t work for some reason. Then I opened brave on one OS and tried, same result. Then I opened brave on both OSes and was able to send and receive files and messages. I haven’t tested further, so I don’t know if its a browser incompatibility or a settings incompatibility.

Hi @Gavaudan,

Haha, no problem. Really appreciate it!

Interesting, Brave is my usual go-to browser, and it wasn’t working for me (on PureOS). Just to clarify though, it always did see the other browsers on the webpage, I was just unable to send a message or file.

However, I didn’t try a “Linux to Linux” connection. It is interesting that on Linux you had to use a very specific browser on both ends - maybe an indication of a generally buggy browser implementation on Linux?

Yeah, same here.

The initial browsers I was using were, specifically, librewolf on manjaro and firedragon on garuda (which is librewolf with some garuda customization). Firefox might work, I didn’t try.

Well, I came up with the idea to try loading up my computer with the live bootup USBs of PureOS, Debian, Elementary OS, Ubuntu and Zorin. All of them are doing the same thing (some had Firefox built in, some had others).

So unfortunately it looks like the issue is something that generally weird with the Linux implementation. Ah well, snapdrop looked like it could have been a really cool addition, lol.

To spin that a bit, linux is secure enough to prevent files sent circumventing safeguard protocols. You just need something that does it properly.