Software App Not Funtioning Librem 15 v4

The Software App on my Librem 15v4 no longer seems to work. It never really worked well out of the box. Now it runs very slow, it shows the “All” apps window from the PureOS repository, you can search for and download software.
However, when you use the “Installed” or “Updates” tab, it stalls out and spins forever…
When I first boot up and connect to the internet I am getting a error saying that the ‘updates aspect did not load because it could not connect to the server’ in paraphrase.
I did some research and what I found says that when PureOS updates, it can break “Updates”…Thoughts or Help Please, is this common for other users out there?

Thinking that this might be VPS related. When I first boot up, I need to manually start my VPN in the network manager. As the computer is booting on a LAN, it connects at boot, to my Intranet, then is fed through my firewall to the net. It worked fine when I set up the machine, no changes have been made to my network, router or firewall settings.

Perhaps…When I engage the tunnel when I engage the VPN which is affecting the secure connection in the OS to its homebase server for the repository, midstream in the process of establishing the connection, the VPN tunnel is created at the same time? I don’t know if that would flag the server for the connection or not?

I tried to use the terminal to set ProtonVPN to auto start at boot like I have on my Fedora box. I think that the Network Manager in PureOS is overriding those commands and probably needs to be disabled for the command line to function. Booting directly into the tunnel would probably fix this issue…I need the time to research this more, anyone have any advice?

I was also messin around setting my network to run everything through Tor, but I was having issues with the Software App before I messed with that, so I don’t think that is an issue.

Lastly I set up Boxes last night, properly, I hope…followed the instructions to the Tee, rebooted, started the software…instantaneous Crash! Not sure if somehow this is related to the above issue…thought I would toss it on the table while were on the subject.
I have never used BOXES before but I have run VirtualBox. I thought I would give it a spin as it came preinstalled, rather than install VirtualBox which is not in the software store, nor is Whonix either, which seems strange to me, considering the essence of why were using Purism products to begin with.

I would like to run Whonix.
Not much out there on these topic’s that I could find.

Yes I know I packed a lot in this, hopefully they kinda interrelated and I didn’t get off on a bunny trail again…feel free to address whatever aspect you wish. I can always use all the help in advance.

Again, thank you Purism, thank you community, your Awesome!!!

Unless you absolutely must use a VPN, the obvious fault isolation would be: don’t start the VPN. (Hence, don’t do anything else, something unusually confidential, that you specifically want to go through the VPN.)

(The act of starting the VPN may well break any pre-existing connections.)

Regardless, assuming you are comfortable at the shell prompt, I would

a) check what repositories you are using
b) update and upgrade from the shell (looking for errors or blockages etc.)

I am following you…
Its a habit, more than anything, boot, tunnel, connect to the net. We also have a company VPN so in order to access my server, it also needs to be connected.
If I am hearing you correctly, boot the system, give it time to phone home and do its thang…see what happens. If were good, were good, then tunnel…
I will give it a shot…
In an age of nano computing…waiting is a novel idea…

Thanks for the input.

Update: I let the machine fully boot and connect to the net before I engaged the tunnel. No difference, same problem…so I don’t think its VPN related, probably along the lines you mentioned, I broke something somewhere in how it phones home.
I will now move to trying A and B as suggested and check the config.

Update for Repository,
I updated the system as directed, and I pulled the repository.
Here’s the list,
sudo grep -rhE ^deb /etc/apt/sources.list*
deb amber main
deb amber-security main
deb unstable main
deb amber-updates main
deb [arch=amd64] xenial main
deb [arch=amd64] xenial main
deb [signed-by=/usr/share/keyrings/riot-im-archive-keyring.gpg] default main
deb [signed-by=/usr/share/keyrings/riot-im-archive-keyring.gpg] default main
deb amber main
deb amber-security main
deb unstable main
deb amber-updates main
unclebunky@Purity:~$ sudo apt-cache policy
Package files:
100 /var/lib/dpkg/status
release a=now
500 xenial/main amd64 Packages
release o=. xenial,a=xenial,n=xenial,l=. xenial,c=main,b=amd64
500 default/main amd64 Packages
500 amber-updates/main amd64 Packages
release v=9,o=PureOS,a=amber-updates,n=amber-updates,l=None,c=main,b=amd64
500 unstable/main all Packages
release o=proton-gitlab,n=unstable,c=main,b=all
500 amber-security/main amd64 Packages
release v=9,o=PureOS,a=amber-security,n=amber-security,l=None,c=main,b=amd64
500 amber/main amd64 Packages
release v=9,o=PureOS,a=amber,n=amber,l=None,c=main,b=amd64
Pinned packages:

Did you do the sudo apt upgrade ? Did it work? Did it give any errors?

yes sir, “sudo apt upgrade” from the shell, as instructed, it worked, it updated as shown, no error messages.
I am however getting the same error message on the Software Application saying there was an issue phoning home. Seems a bit like an oxymoron in what it says, “pureos amber InRelease is not (yet) available (Could not connect to repo…”
If you click on the X and close that, the Software Application says it wants to restart and install the update…
Scratchin my head here.

Did you try to update after connecting to the net but before connecting to the vpn?

Yes sir I did. It installed the update, and now it appears that it’s ready for another. What is odd is that it said that the update was not available. It says the connection timed out. You close out of that, there’s the update, ready to install on a reboot. Reboot and it updates. A couple days ago before I updated in the terminal as instructed by kieran, I could not even get the software store to load in the Software App, let alone what was installed, or what needed updating. Were makin headway here, at least now its updating again…abet after it says it cant.

Maybe one of them Linux Glitch Gremlins that keeps yankin my chain, or is there something else at the Root of this issue in why its saying the update is not available yet and the connection timed out, yet there’s the update, ready to roll upon reboot.

In other distros (never used PureOS, so your mileage may vary), I have seen the GUI application give up more easily than the CLI. A guess here, but perhaps the Store application is giving an error because one source times out, but the others do not, so there are still updates to install. I have also seen the GUI start to cooperate after using the CLI to update.

Moral of the story: sometimes the GUI handles errors differently than the CLI such that the CLI will try harder while the GUI gives up more easily. If the Store can’t update, try apt or apt-get(as you have done). An interesting experiment might be to try sudo apt updatein the terminal and then see what the Store says is available to update once the command finishes executing.

1 Like

So its probably a GUI Gremlin, makes total sense, I will follow your advice, load the terminal and see if there’s other updates that should be installed via CLI and give you an update.
Never a dull moment in Linux, learn something new everyday. :thinking:
I appreciate your time to help me understand this hiccup.

Update, ran the sudo apt updatein in command in the terminal, said its not a valid command. Must have a typo, never heard of that command before.

Update, not updatein. I missed a space earlier.

Thought maybe it was a new version of Linux :roll_eyes:
Kinda figured that was what you meant.
I ran sudo apt update and some packages wanted to upgrade, so I upgraded them. I will see how things work now.
Thanks again for your help.


It’s flattering that you trust me so implicitly, and I shall redouble my efforts toward clarity so that I earn that implicit trust.

1 Like