Software app not working


#1

Was working fine yesterday morning, but now the software app just gives me this?

Any way to fix it?


#2

Could you please explain a bit more, what is “this”?


#3

I’m guessing it’s some sort of appstore that Purism includes in PureOS?

That was my guess when I saw this.


#4

‘this’ is the screen showed in the screenshot. @tez wanted to install software on his computer. Usually when one opens “Software” on a Pure OS computer, it opens with a list of featured applications, unfortunately, this time it only opened with the screen shown in the shot.

The screen shown in the shot shows no available applications (Editors Picks is empty) and is therefore presumably useless to @tez who presumably was hoping to install software when he opened the application called “Software”.

I have problems like this all the time with Gnome Software. It hangs randomly, doesn’t show anything, takes minutes to load a search, etc. I, therefore, do not use Gnome Software as it barely works for its intended purpose (for me).

TLDR; Gnome Software never works for me either.


#5

Sorry, I just now saw the screenshot.

Has this happened after a kernel update?


#6

Thanks for the explanation blendergeek, yes that’s exactly what it is.

It stopped working yesterday and even after several reboots wouldn’t load properly. Then, randomly, it began working again, however now the extensions page doesn’t load properly. It also shows an error whenever I load or switch screens (i.e)

MAIN PAGE LOADS FINE NOW

SHELL EXTENSIONS PAGE NOW SHOWS NOTHING


#7

@tez, please fully update your system (run sudo apt update && sudo apt full-upgrade in Terminal), it might solve your issue. Also make sure you have pureos-desktop package installed (sudo apt install pureos-desktop).


#8

Thanks Mladen.

I already had pureos-desktop installed. I ran the sudo update command (as I have over the last several days), however this time it looks to have fixed it. Thanks to whatever change you made. Loading Software, it asked me to restart gnome, and once it did, it threw an error again, but after restart of the program it didn’t show any errors. However, on every start after that, I still get the error message when it starts, but now I have a normal app start screen and I get a full shell extension list.

Cheers!