Software & Updates has disappeared


#1

Good Day to you all.

It seems as though the Software & Updates has disappeared I have tried all the fixes from the post on Jan 1.

Any steps to get it back would help greatly.

I am only barely wading my way through this wondrous but as of yet murky world of Gnome Pure OS

Ron


#2

That application has been problematic on PureOS for months now. I am not certain to which Jan. 1 post you are referring, so it is unclear if you are seeing the same thing as the rest of us. Nevertheless, you may wish to follow this tracking item.

If your situation is different, you can try forcing a reinstall of that package using the --reinstall option on an apt install command.


#3

Hello Wayne,

It doesn’t really bother me. on a functional level. The only issue Ii have is where I am getting my downloads from. Choosing a repository seems to evade me.

Is there another way to locate downloads repositories?

Thanks again,

Ronan


#4

You can try ‘less /etc/apt/sources.list’.

PS. I should mention that there may be a sub-directory ‘sources.list.d’ that may also include repositories. You may want to look at that too.


#5

Perfect,

Thanking you

Ronan


#6

My guess is that there is a push to shift over to GNOME Software, so I suspect that is why that application disappeared.

You can also check repos in GNOME software by clicking the top left “Software” drop down in the top bar and checking “Software Repositories”

Shown here from Fedora on my laptop:


#7

That’s interesting. Unfortunately, on PureOS, “Software” appears to have the same error as “Software and Updates” when invoking the “Software Repositories” option:

ERROR:root:Cannot import UbuntuDrivers: No module named 'UbuntuDrivers'
  Traceback (most recent call last):
  File "/usr/bin/software-properties-gtk", line 101, in <module>
  app = SoftwarePropertiesGtk(datadir=options.data_dir, options=options, file=file)
  File "/usr/lib/python3/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py", line 109, in __init__
    SoftwareProperties.__init__(self, options=options, datadir=datadir)
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 109, in __init__
    self.reload_sourceslist()
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 599, in reload_sourceslist
    self.distro.get_sources(self.sourceslist)
  File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 93, in get_sources
    (self.id, self.codename))
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for PureOS/green

Based on the comments in the tracking item, it sounds like a python package is missing the correct information.


#8

For those not following the task, this should be fixed shortly in python-apt >= 1.8.4pureos1.


#9

UPDATE: i just took this package update–I did not realize it would be today–and it does not work for me. I reopened the task for a response.


#10

Two other updates are also needed:

base-files >= 10.1pureos4 
lsb-release >= 10.2019031300pureos1

I tried them and it works now.