[SOLVED] Add usb HUB to another HUB

I tried to connect a usb HUB to C31MINIDOCK4KPD HUB but it didn’t recognize it on the phone. Is it because I used a cheap 2$ usb HUB?

Does the Hub require to be powered?

Yes, it requires to be powered.

To clarify that question … a USB device is either

  • bus-powered, or
  • self-powered (and in the case of a USB hub that is often just described as “powered”).

Was the dock on mains power? I suggest that particularly if you are going to chain USB hubs then the dock should be on mains power so that there is enough power available to

  • power the dock itself (including the built-in functions of HDMI output and ethernet)
  • power the hub that is connected to the dock
  • power all the actual USB devices that might be connected to the dock
  • charge the Librem 5 (or at least maintain the level of charge).

Not putting the dock on mains power and trying to power all that from the Librem 5 might be a problem.

lsusb is your friend. Before and after plugging in the 2$ USB hub.

For fault isolation, confirm that the 2$ USB hub works at all e.g. when connected directly to the phone or better still when connected directly to a random computer.

the 2$ USB hub only recognizes windows partitions :man_facepalming:

OK, that must be a new low in lameness.

On the face of it, I don’t understand how that is even possible. A hub shouldn’t care what is on a USB mass storage class device. A USB mass storage class device is an array of blocks. What partition table is used and what file systems are on each partition shouldn’t matter. That should apply even when a dock (kind of a hub) has a built-in (u)SD card reader, as some do, even though the interface from the dock to the card is then probably an SD interface.

However I understand that cheap and nasty implementations never fail to surprise.

For $2 it’s probably not worth persevering with.


Did you find a hub that works? I just bought the cheapest I could find (Lemorele brand) to play with it. It works briefly, but the monitor keeps flicking on and off. The wireless mouse doesn’t work either. It is a powered hub, but that doesn’t seem to make a difference.

The official unofficial answer is here: https://source.puri.sm/Librem5/community-wiki/-/wikis/Tested%20Accessories#hubs i.e. where customers document their experiences, success or fail. It probably isn’t completely up to date though.

I’ve actually gone off in the “lapdock” direction.

1 Like

Also Purism sells one in the store.

1 Like