[Solved] Librem 13 v3 refuse to charge while turned on


I received my Librem 13 a few days ago, and at first, I thought the charger is not working - it made a high pitch noise, the charging light didn’t come on, no charging indicator on the UI. Later I found that my Librem 13 will only charge when it is off, but refuse to charge when it is on. If I plug in my Librem 13 when it is on, the charger will produce the high pitch noise, and refuse to charge. Is there anything I can do?

Are you using the charging cable and brick that came with the Librem?

Yes. I have also found that it will charge if I enter standby mode.

Where to you do the settings for ‘standby mode’, are you in the control settings for Power?

By standby mode I mean suspend. I did it by running pm-suspend.

I am also having this issue recently. The Librem 13 v3, which I received not more than a week or so ago, does not charge when the power is on – especially near the end of the battery cycle, when it’s low. Sometimes the laptop will not even charge when the power is off. It’s finicky. Running cat /sys/class/power_supply/BAT/uevent on the battery doesn’t reveal anything interesting, unfortunately.

Any updates on this for anyone?

UPDATE: Unplugged the battery from the laptop mobo to see if I could run it strictly from adapter power. Didn’t budge. Shoved my multimeter down the tube of the plugged-in charger and noticed no output. Changed pronged input plug to see if that would resolve it – nothing. Contacted ops support to let them know I have a faulty charger.

@KingsLee, if you have one on hand, have you tried testing your charger with a multimeter?

I have tested it with multimeter, but the best I can do is seeing that the adapter is outputing 20V when it is not plugged into the computer. I dare not connect extra wires to test yet.

My contact with support recommended me to unplug the battery from Librem 13 overnight, but it didn’t solve the issue.

I have tested it repeatedly, and luckily mine is able to start charging once it is in power off / standby state. Also I am able to run my notebook without the battery.

Also the adapter is making a high pitch noise when it is supposed to charge but not. The noise increases if I press on the adapter’s plastic shell.

Sounds like you might want to request a replacement charger, @KingsLee. It’s possible your charger’s capacitors (or other components) were damaged by spikes, surges, etc. – that’s typically the kind of sound that happens in those cases. Can’t hurt.

If you’re interested in knowing more about what your battery is doing, you might run

cat /proc/acpi/battery/BAT0/info

(or BAT1, depending on how the system labels it)

My replacement charger is on the way, in the meantime I was able to find a charger from the local shop with the same rating, and the symptoms were the same. I hope I need not to replace my Librem…

I did try the command, and the battery info showed “discharging” while having the charger plugged in.

I’m sorry to hear that. Oof.

At most, if your battery is not cycling properly, you may just have to replace it, which isn’t too hard (cf., https://wiki.puri.sm/hw/L13/v3). I doubt it would be a motherboard issue if, after running cat on the hardware, the terminal’s returning with ‘discharge;’ that might imply it’s working with that side of the hardware well.

If the new charger doesn’t do it, I might request a new battery, to boot. Good luck!

1 Like

Have you checked this thread to see if it resolves your issue?

I was wondering who is responsible for deciding when to charge - the motherboard circuit, coreboot, battery or the charger? I tend to think that it is not the charger, it seems to me that it simply supplies voltage.

@chirospasm I hope the charger will solve this problem, as shipping the battery is difficult these days.

@vrata Thanks for pointing this out, that provides a little comfort. It seems that charging a notebook is really difficult - it has all sort of issues - the topic seems to be about refusing to charge when standby, but mine is exactly the reverse.

It is a charger problem.

Today I received my new charger and so far everything seems to work as expected - no need to go into Standby mode to start charging.

1 Like

Yesterday I had a similar problem with my Librem15rev3 - I had the laptop connected to power, but failed to notice that it was not charging. So in the middle of a video conference, the screen turns black (why there wasn’t a “battery low” notice?). At home, in the evening I opened it up because I feared that there was a problem witth he connections of the power inlet, but this looked fine. So I connected it to my spare charger which came with my Librem15rev2, and everything worked normally. So I thought that I had found the problem and wanted to write to Purism Support for a new charger. However, this morning for some reason I thought I could also try to see if it was the cable, and yes: Connecting the “new” chargers cable to the “old” charger showed no sign of power coming through. So I just need to get a new cable. But how likely is it that these cables fail? It looks quite sturdy and robust, and I am sure that it didn’t get a 10A overload…I am puzzled.