Starred files - when I click it, nothing happens

Has anybody found a solution to the following problem? I would like to use the “Star” option in Files, but when I click on it (either in the small menu or when I click on the “empty” star next to the file), nothing happens. I also cannot drag and drop it into the category.

Is the file that you are trying to “star” in or under your Home directory, or outside your Home directory?

more importantly … what do YOU expect to happen ?
have you looked under ‘Starred’ in the default GNOME file-manger ?
i don’t use ‘star’ instead i just use links …

Yes, in the Home directory.

Yes, the star should turn black and the document should show up in the category “Starred” which is both not the case.

That’s odd - because the complete non-functioning of “star” outside the home directory is a known limitation. I can certainly reproduce that. Star works in my home directory tree and does not work outside it - even for remote files that are mounted into my home directory tree.

From what I’ve read, the implementation of “star” is fairly funky - so the non-functioning for you does not really surprise me even though it is not what I would expect.

Goodness knows why they didn’t use extended attributes. That should at least make it work for all local files (but then is doubtful to work for remote files).

1 Like

I should add that any implementation of “star” that involves storing file metadata outside of the original file system is a potential security risk i.e. leaks information from one file system to another. Hence, for example, if the original file system is encrypted (possibly even with deniable encryption) but the metadata for “star” is stored in your home directory tree (as I believe it currently is) then your encryption is at least partially broken.

Against that, a secure implementation will probably mean that you can’t “star” files that are on read-only media, such as a CD-ROM, or simply where the file is read-only to you. So there are trade-offs.

2 Likes

Maybe, Purism disabled it for security reasons? However, in that case, this would be a known issue…

Maybe. You would have to ask them. support@puri.sm